Bug 1747943 - dmlite-dpm-tester fails to install in Fedora rawhide
Summary: dmlite-dpm-tester fails to install in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dmlite
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: oliver.keeble
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1738911
Blocks: F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-09-02 10:24 UTC by Miro Hrončok
Modified: 2019-10-22 21:14 UTC (History)
6 users (show)

Fixed In Version: dmlite-dpm-tester-1.13.99-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 21:14:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-09-02 10:24:14 UTC
dmlite-dpm-tester-1.13.1-2.fc31.x86_64 fails to install in Fedora rawhide:

  nothing provides python2-libs needed by dmlite-dpm-tester-1.13.1-2.fc31.x86_64

This is caused by the python27 package.

Please, don't require python2-libs package directly. If you need Python 2 in Fedora 32+, you need to request a FESCo exception.

Comment 1 Miro Hrončok 2019-09-10 10:56:37 UTC
In preparation for the Python 2 EOL, we are removing all non-installable Python 2 packages:
https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

This bug is still in the NEW state and the package does not install. Please indicate you are working on a fix by setting the state to ASSIGNED. When this bug is four weeks in the NEW state, the package may be orphaned.

Note that you don't have to actually fix this right now, setting the bug to ASSIGNED will just mark this as being worked on, so I'll know it is being taken care of. If this happens too quickly, feel free to reach to me any time for help (with specific problems).

(If you know for sure this package shall be removed, consider doing it.)

Thank You!

Comment 2 oliver.keeble 2019-09-13 12:24:57 UTC
Hi,

I've removed this dependency on python2 in the latest builds, e.g.

https://koji.fedoraproject.org/koji/taskinfo?taskID=37630135

Is this enough? 

Thanks,

Oliver.

Comment 3 Miro Hrončok 2019-09-13 17:13:20 UTC
No, sorry, the package still doesn't install, however from a different reason now:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3-gfal2 needed by dmlite-dpm-tester-1.13.99-1.fc32.x86_64

Comment 4 oliver.keeble 2019-09-16 11:14:36 UTC
Hi,

python3-gfal2 is on its way!

https://koji.fedoraproject.org/koji/buildinfo?buildID=1377817

Oliver.

Comment 5 Zbigniew Jędrzejewski-Szmek 2019-10-22 21:14:52 UTC
Seems all good now:
$ sudo dnf install dmlite-dpm-tester
Dependencies resolved.
====================================================================================================================
 Package                              Architecture       Version                          Repository           Size
====================================================================================================================
Installing:
 dmlite-dpm-tester                    x86_64             1.13.99-2.fc32                   rawhide              21 k
Installing dependencies:
 CGSI-gSOAP                           x86_64             1.3.11-7.fc32                    rawhide              52 k
 boost-python3                        x86_64             1.69.0-11.fc32                   rawhide             104 k
 davix-libs                           x86_64             0.7.5-1.fc32                     rawhide             471 k
 gfal2                                x86_64             2.16.3-3.fc32                    rawhide              83 k
 gfal2-plugin-file                    x86_64             2.16.3-3.fc32                    rawhide              17 k
 gfal2-plugin-gridftp                 x86_64             2.16.3-3.fc32                    rawhide              84 k
 gfal2-plugin-http                    x86_64             2.16.3-3.fc32                    rawhide              42 k
 gfal2-plugin-srm                     x86_64             2.16.3-3.fc32                    rawhide              44 k
 gfal2-plugin-xrootd                  x86_64             2.16.3-3.fc32                    rawhide              55 k
 globus-callout                       x86_64             4.2-1.fc32                       rawhide              22 k
 globus-common                        x86_64             18.5-1.fc32                      rawhide             136 k
 globus-ftp-client                    x86_64             9.2-2.fc31                       rawhide             107 k
 globus-ftp-control                   x86_64             9.4-2.fc31                       rawhide              79 k
 globus-gass-copy                     x86_64             10.5-1.fc32                      rawhide              41 k
 globus-gass-transfer                 x86_64             9.1-2.fc31                       rawhide              48 k
 globus-gsi-callback                  x86_64             6.1-2.fc31                       rawhide              45 k
 globus-gsi-cert-utils                x86_64             10.3-1.fc32                      rawhide              23 k
 globus-gsi-credential                x86_64             8.1-2.fc31                       rawhide              39 k
 globus-gsi-openssl-error             x86_64             4.1-2.fc31                       rawhide              21 k
 globus-gsi-proxy-core                x86_64             9.4-1.fc32                       rawhide              40 k
 globus-gsi-proxy-ssl                 x86_64             6.2-1.fc32                       rawhide              20 k
 globus-gsi-sysconfig                 x86_64             9.2-3.fc32                       rawhide              34 k
 globus-gss-assist                    x86_64             12.2-2.fc31                      rawhide              39 k
 globus-gssapi-error                  x86_64             6.1-2.fc31                       rawhide              18 k
 globus-gssapi-gsi                    x86_64             14.11-1.fc32                     rawhide              74 k
 globus-io                            x86_64             12.2-1.fc32                      rawhide              46 k
 globus-openssl-module                x86_64             5.1-2.fc31                       rawhide              17 k
 globus-xio                           x86_64             6.2-1.fc32                       rawhide             169 k
 globus-xio-gsi-driver                x86_64             5.2-1.fc32                       rawhide              40 k
 globus-xio-popen-driver              x86_64             4.1-1.fc32                       rawhide              24 k
 gsoap                                x86_64             2.8.91-1.fc32                    rawhide             715 k
 pugixml                              x86_64             1.10-1.fc32                      rawhide             107 k
 python3-gfal2                        x86_64             1.9.5-5.fc32                     rawhide             141 k
 srm-ifce                             x86_64             1.24.3-7.fc32                    rawhide             191 k
 voms                                 x86_64             2.1.0-0.14.rc0.fc32              rawhide             158 k
 xrootd-client-libs                   x86_64             1:4.10.1-2.fc32                  rawhide             721 k
 xrootd-libs                          x86_64             1:4.10.1-2.fc32                  rawhide             612 k

Transaction Summary
====================================================================================================================
Install  38 Packages

Total download size: 4.6 M
Installed size: 15 M
Is this ok [y/N]:


Note You need to log in before you can comment on or make changes to this bug.