Bug 174799 - Header file modes are corrupted in devel package.
Header file modes are corrupted in devel package.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 06:49 EST by Alistair Riddoch
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: avahi-0.6-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 07:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alistair Riddoch 2005-12-02 06:49:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The headers files in /usr/include/avahi-compat-howl/discovery/ appear to have
corrupted modes, so the output of ls looks like the following:

[ajr@click ~]$ ls -l /usr/include/avahi-compat-howl/discovery/
total 0
?--------- ? ? ? ?            ? /usr/include/avahi-compat-howl/discovery/discovery.h
?--------- ? ? ? ?            ? /usr/include/avahi-compat-howl/discovery/text_record.h

The filenames are highlighted in red, and flashing, as they would be if they were broken links. Attempting to access the files as a normal user results unsurprisingly in a Permission Denied error, but when accessed as root the files appear to be intact.

At first glance this looks like a filesystem corruption error, so at first I assumed the kernel or hardware was to blame. However, installing the avahi-devel on Fedora Core 3 system or a different Fedora Core 4 system using --nodeps results in exactly the same corrupted permissions.

Version-Release number of selected component (if applicable):
avahi-devel-0.6-2

How reproducible:
Always

Steps to Reproduce:
1. Install avahi-devel
2. List the contents of the /usr/include/avahi-compat-howl/discovery/ directory.
3.
  

Actual Results:  The permissions in the directory are corrupted.

Expected Results:  The permissions in the directory should be 644, as is normal for header files.

Additional info:

Attempting to use chmod does not fix the problem, probably because the files type is invalid, giving the ? in the first character of the mode representation.
Comment 1 Jason Vas Dias 2005-12-02 17:14:09 EST
Yes, sorry, this was a problem with avahi-devel-0.6-1 - 2 - 
fixed with avahi-0.6-3+ (current release avahi-0.6-5) . 
Doing a 'yum update avahi' should fix this for you.
Comment 2 Alistair Riddoch 2005-12-04 08:43:47 EST
I see exactly the same problem in 0.6-5. I have removed and reinstalled the
package several times to confirm, including removing and redownloading the
package from the yum cache directory.
Comment 3 Jason Vas Dias 2005-12-05 14:51:07 EST
Very sorry about this - the original .spec file '%defattr' statements were
wrong and did not give search permission to directories - this is now 
definitely fixed for all directory levels in avahi-0.6-6 .
Comment 4 Alistair Riddoch 2005-12-06 07:09:10 EST
confirmed

Note You need to log in before you can comment on or make changes to this bug.