Bug 174835 - kill man/info documentation bugs
kill man/info documentation bugs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 11:56 EST by Steve Bonneville
Modified: 2008-05-09 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 04:43:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2005-12-02 11:56:13 EST
Description of problem:

The man page and info pages for kill(1) list options that don't exist.

The man page claims there are -a and -p options to kill(1).

The info page claims there are -t/--table options which are synonyms for -l,
it also claims kill supports --help and --version which it does not.  However,
the info page for kill appears to come from the coreutils package, while the man
page for kill(1) appears to come from the util-linux package, as does the
version of /bin/kill that we ship.  (/usr/bin/kill is a symlink to /bin/kill).

Running /bin/kill without arguments displays the following usage message:

[user@foobar ~]$ kill
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l
[sigspec]

Version-Release number of selected component (if applicable):

util-linux-2.12a-16.EL4-12
coreutils-5.2.1-31.2
Comment 1 Karel Zak 2006-01-03 04:42:54 EST
There're two "kill" implementation. The man page kill(1) is correct, because
it's for /bin/kill.

the kill command from util-linux:

  $ /bin/kill
  usage: kill [ -s signal | -p ] [ -a ] pid ...
         kill -l [ signal ]

bash buil-in command:

  $ help kill
  kill: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l  
[sigspec]

By the way, see kill(1) man page, there is note about it: "Most modern shells
have a builtin kill function..."

Note You need to log in before you can comment on or make changes to this bug.