Bug 174850 - loadkeys get permission denied as regular user
loadkeys get permission denied as regular user
Status: CLOSED DUPLICATE of bug 172425
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 14:19 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 14:39:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2005-12-02 14:19:16 EST
Description of problem:
Whenever I login as a regular user  I get:

Keymap 0: Permission denied
Keymap 1: Permission denied
Keymap 1: Permission denied
KDSKBENT: Operation not permitted
loadkeys: could not deallocate keymap 3

I get the same message if I do loadkeys -d.  The command succeeds as root. 
Interestingly, if I do 'setenforce 0' and relogin I still get the same message.

The loadkey command seems to be run by /bin/unicode_start which is called by
/etc/profile.d/lang.sh.  Because loadkey fails the rest of the user profile and
.bashrc is not loaded.


This is a fresh install updated to devel repo as of 12/2/05.

Version-Release number of selected component (if applicable):


How reproducible:
at every login


Steps to Reproduce:
1. Fresh install
2. Login as regular user
3.
  
Actual results:
initial profile execution fails because loadkeys fails


Expected results:
loadkeys succeeds and user profiles complete execution


Additional info:

my $LANG environment was set to en_US.UTF-8
Comment 1 Miloslav Trmač 2005-12-02 14:39:53 EST
The kernel has prohibited changing the keymap by regular users recently, so
kbd-1.12-12 doesn't call loadkeys in unicode_start any more.

Thanks for your report.

*** This bug has been marked as a duplicate of 172425 ***

Note You need to log in before you can comment on or make changes to this bug.