Bug 174851 - "make" of evolution keeps going through errors
"make" of evolution keeps going through errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 14:49 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 09:27:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-12-02 14:49:05 EST
Building evolution for some reason appears to be doing the equivalent of a make
-k/--keep-going i.e. it carries on after errors, only reporting a failure at the
end.

(This is a pain because a build typically takes up to 45 minutes and I'd like to
know immediately when it dies; I turned this on myself when fixing up missing
declarations, but I thought I'd turned it off)
 
evolution-2.4.2 is doing this; I think I've seen it with 2.4.1 as well
Comment 1 Matthew Barnes 2007-03-26 00:50:28 EDT
Would -Wfatal-errors help?
Comment 2 Matthew Barnes 2007-03-26 00:51:21 EDT
... he wonders to himself since Dave is probably no longer interested.
Comment 3 Dave Malcolm 2007-03-26 14:04:16 EDT
mbarnes: so are you seeing this behaviour, or was it just me?
Comment 4 Matthew Barnes 2007-03-26 15:44:12 EDT
Maybe.  When building packages I usually just dump the output to a file and sift
through it once rpmbuild finally aborts.  The error usually appears somewhere in
the middle of the file.

But I've not seen this when building from GNOME CVS/Subversion.  Compilation
errors abort immediately, as expected.
Comment 5 Matthew Barnes 2007-10-31 09:27:01 EDT
I think this might be related to the RPM builds using multiple processors. 
Compilation on one processor fails but the other ones finish their tasks before
noticing the other processor has failed.  I don't know, just a guess.

In any case, I usually just dump build output to a log file and look at that for
errors, so this isn't really getting in my way.  Closing as WONTFIX just to get
it off my bug list.

Note You need to log in before you can comment on or make changes to this bug.