Bug 174871 - searches excluding blocker list residence seem broken
searches excluding blocker list residence seem broken
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-02 19:58 EST by Ernie Petrides
Modified: 2013-06-23 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 14:33:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 467389 None None None Never

  None (edit)
Description Ernie Petrides 2005-12-02 19:58:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
It seems that advanced bugzilla searches using the OtherBugsDependingOnThis
field do not correctly allow for exclusion of those bugs already on a blocker
list.  (The desired goal is to search for bugs that are not currently on one of
the two appropriate blocker lists, so that, once identified, they can be fixed.)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. choose the advanced bugzilla query mechanism
2. select "only include" bugs numbered: 173280
3. under "Advanced Searching Using Boolean Charts", select these values:
      "OtherBugsDependingOnThis" : "does not contain the string" : 168424

Actual Results:  A bug list is generated that *does* include 173280.  This is wrong
because that bug blocks two different other bugs: 168424 and 171043

Expected Results:  The bug list should be empty.

Additional info:

I've tried over a dozen combinations of negating charts and various ways
of searching for words, strings, regexps, and such in that field.  It seems
that every bug that blocks multiple others is wrongly included in the result.
Comment 1 David Lawrence 2008-09-16 12:54:03 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 2 David Lawrence 2008-12-01 14:33:53 EST
Filed upstream.

https://bugzilla.mozilla.org/show_bug.cgi?id=467389

Note You need to log in before you can comment on or make changes to this bug.