Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1748799 - Ordering in Usage Report table will re-send getting report requests
Summary: Ordering in Usage Report table will re-send getting report requests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.2.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-04 08:12 UTC by Yadan Pei
Modified: 2019-10-16 06:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:40:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:40:22 UTC

Description Yadan Pei 2019-09-04 08:12:45 UTC
Description of problem:
The first time we click on ordering arrow in Usage Report table it will send report requests again, it looks like other resource pages will not resend the request when clicking on ordering 

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-09-03-102130

How reproducible:
Always

Steps to Reproduce:
1. cluster admin enable Metering 
2. Visit Administration -> Chargeback, click 'Create Report' using example YAML
3. After report is generated, check Usage Report table
4. Clicking on ordering arrow

Actual results:
3. The first time we click ordering arrow, it will re-send requests to get report data

Expected results:
3. After report data is loaded, it's unnecessary to send the request again when ordering

Additional info:

Comment 2 Yadan Pei 2019-09-09 05:38:41 UTC
Clicking on reordering will not send another report request

Verified on 4.2.0-0.nightly-2019-09-08-180038

Comment 3 errata-xmlrpc 2019-10-16 06:40:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.