Bug 1748814 - Backport request of BZ#1579729 haproxy log shows warning message: 'option tcplog' directive is ignored in backends
Summary: Backport request of BZ#1579729 haproxy log shows warning message: 'option tcp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.11.0
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.11.z
Assignee: Anand Paladugu
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-04 08:45 UTC by David Hernández Fernández
Modified: 2019-11-18 14:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 14:52:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23752 0 None None None 2019-09-09 15:22:55 UTC
Red Hat Bugzilla 1579729 0 medium CLOSED [haproxy1.8.8] haproxy log shows warning message: 'option tcplog' directive is ignored in backends if set env ROUTER_SYS... 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2019:3817 0 None None None 2019-11-18 14:52:18 UTC

Internal Links: 1579729

Description David Hernández Fernández 2019-09-04 08:45:31 UTC
Description of problem: Backport Request from 4.1 to 3.11 of BZ#1579729

Version-Release number of selected component (if applicable):
Openshift v3.11.135
Haproxy18-1.8.14-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. oc env dc/router ROUTER_SYSLOG_ADDRESS=127.0.0.1
2. oc logs router-x-xxxxx

Actual results:
haproxy log shows warning messages for all passthrough routes (be_tcp)

Expected results:
should not shows warning messages in haproxy router log.

Additional info:
Harmless, but it shows repeatedly in log while router reloaded.

Comment 1 Anand Paladugu 2019-09-06 14:47:19 UTC
Identified, and added modifications to 3.11 code and did a pull request.

https://github.com/openshift/origin/pull/23742

Comment 2 Anand Paladugu 2019-09-09 14:54:27 UTC
Pull request:

https://github.com/openshift/origin/pull/23752

Comment 3 David Hernández Fernández 2019-10-24 09:42:03 UTC
I can see that https://github.com/openshift/origin/pull/23752 has been merged. Is this planned for next OCP 3.11.z release? Or any info provided is appreciated. Thank you Anand.

Comment 5 Hongan Li 2019-11-05 03:38:38 UTC
verified with v3.11.154 and issue has been fixed.

Comment 7 errata-xmlrpc 2019-11-18 14:52:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3817


Note You need to log in before you can comment on or make changes to this bug.