Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1748823 - Some reports data are not shown correctly and sorting doesn't work
Summary: Some reports data are not shown correctly and sorting doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-04 09:04 UTC by Yadan Pei
Modified: 2019-10-16 06:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:40:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
ClusterCPUCapacityHourly-UsageReport (56.20 KB, image/png)
2019-09-04 09:06 UTC, Yadan Pei
no flags Details
cluster-memory-usage-hourly (73.71 KB, image/png)
2019-09-10 02:21 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2605 0 None closed Bug 1748823: Some reports data are not shown correctly and sorting doesn't work 2020-06-03 09:04:28 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:40:41 UTC

Description Yadan Pei 2019-09-04 09:04:16 UTC
Description of problem:
Some reports headers which have more than 4 columns are not shown correctly in Usage Report table, also the ordering on last column doesn't work

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-09-03-102130

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin enable Metering
2. Visit Administration -> Chargeback, create cluster-cpu-capacity-hourly report
3. Visit report data in Usage Reports table

Actual results:
3. The last 3 columns header and sorting arrow overlaps
When order by the last column 'avg node count', the data is not ordered correctly

Expected results:
3. Table should be shown correctly, also the ordering should work correctly


Additional info:

Comment 1 Yadan Pei 2019-09-04 09:06:09 UTC
Created attachment 1611419 [details]
ClusterCPUCapacityHourly-UsageReport

Comment 3 Yadan Pei 2019-09-10 02:21:23 UTC
1. Cluster admin enable Metering and create report/cluster-memory-usage-hourly
2. After several hours, view data in Usage Report table
3. Click on total cluster usage memory byte seconds, avg cluster memory usage bytes, avg pod count, the orders can be correctly re-ordered

Verified on 4.2.0-0.nightly-2019-09-08-180038

Comment 4 Yadan Pei 2019-09-10 02:21:55 UTC
Created attachment 1613408 [details]
cluster-memory-usage-hourly

Comment 5 errata-xmlrpc 2019-10-16 06:40:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.