Bug 1748936 - Fedora with kernel 5.2.9 drains battery during suspend and remains warm
Summary: Fedora with kernel 5.2.9 drains battery during suspend and remains warm
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-04 13:52 UTC by Guy Marom
Modified: 2019-10-11 14:42 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
Kernel logs (214.92 KB, text/plain)
2019-09-04 17:36 UTC, Guy Marom
no flags Details

Description Guy Marom 2019-09-04 13:52:23 UTC
1. Please describe the problem: battery is drained while computer is suspended and the computer remains warm
My machine is a Lenovo P1 Gen2

2. What is the Version-Release number of the kernel: 5.2.9


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 : not sure


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
a. Close computer lid so it will go to suspend (or user `systemctl suspend`)
b. Go to sleep
c. Wake up, touch computer - lid is warm. Resume from suspend and notice battery drained 30-40%

Reverting to kernel 5.1.20 solved this issue



5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``: haven't tried


6. Are you running any modules that not shipped with directly Fedora's kernel?: nvidia drivers


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Guy Marom 2019-09-04 13:55:52 UTC
I tried attaching the kernel logs but I receive an "ERR_ACCESS_DENIED"

Comment 2 Guy Marom 2019-09-04 17:36:23 UTC
Created attachment 1611606 [details]
Kernel logs

Comment 3 Alex Mason 2019-10-02 15:49:56 UTC
seeing the same issue on my P1 gen 2 under archlinux (5.3.1-arch1-1-ARCH). i noticed the same thing in my logs that "ACPI: Preparing to enter system sleep state S3" and "ACPI: Waking up from system sleep state S3" occur after resume within milliseconds of eachother
currently running the machine with dedicated graphics set in bios, if that matters

Comment 4 Tilen Leban 2019-10-03 07:29:13 UTC
I have the exactly same issue on my P1 gen 1 on Fedora 30 and I'm also running on the dedicated graphic card with proprietary drivers. The last kernel without this issue is 5.1.20.

Comment 5 anton tiniakov 2019-10-07 20:48:12 UTC
I had exactly the same issue with my "X1 Extreme Gen2"(which is almost identical to P1). After suspend the laptop was warm. And battery was draining at a rate around 10% in one hour. In my case removing all `acpi_osi` from kernel command line helped. I had 
"'acpi_osi=! acpi_osi=\"Windows 2009\" acpi_osi=Linux".  Now laptop is cold during the suspend and battery draining at the rate 1% per hour.

Kernel: 5.2.15
Lenovo Bios: 1.25


Note You need to log in before you can comment on or make changes to this bug.