Bug 174894 - AMD X2 not being recognised, not seeing both cores
AMD X2 not being recognised, not seeing both cores
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 11:12 EST by John Ellson
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 17:58:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from 2.6.14-1.1632_FC5 - sees 2 cores (22.47 KB, text/plain)
2005-12-03 16:13 EST, John Ellson
no flags Details
dmesg from 2.6.14-1.1737_FC5 - sees 1 core (22.76 KB, text/plain)
2005-12-03 16:17 EST, John Ellson
no flags Details
dmesg from 2.6.14-1.1674_FC5 - sees 2 cores (20.31 KB, text/plain)
2005-12-03 16:55 EST, John Ellson
no flags Details
dmesg from 2.6.14-1.1682_FC5 - sees 1 core (22.74 KB, text/plain)
2005-12-03 16:56 EST, John Ellson
no flags Details
dmesg from 2.6.14-1.1783_FC5 - sees 1 core (21.82 KB, text/plain)
2005-12-23 14:33 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2005-12-03 11:12:52 EST
Description of problem:
According to /proc/cpuinfo my AMD X2 processor is not being recognised and
it is only seeing one of teh two cores.     Or is this a BIOS problem???

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1737_FC5

How reproducible:
100%

Steps to Reproduce:
1. cat /proc/cpuinfo
2.
3.
  
Actual results:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 35
model name      : AMD Hammer Family processor - Model Unknown
stepping        : 2
cpu MHz         : 2412.394
cache size      : 1024 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow
pni lahf_lm
bogomips        : 4829.88
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp



Expected results:


Additional info:
Comment 1 Ignacio Vazquez-Abrams 2005-12-03 11:37:51 EST
Does it work if you boot with the SMP kernel?
Comment 2 John Ellson 2005-12-03 12:50:55 EST
Its an X86_64.  My understanding is that all te x86_64 kernel aer SMP and thats
why there isn't a separate smp.x86_64.rpm in Fedora.   Am I wrong?

Another possibility is that it is just DaveJ's personal kernal builds that are
not SMP?  I picked up 1737 from his people.redhat.com directory earlier this
morning to investigate a different bug.
Comment 3 Ignacio Vazquez-Abrams 2005-12-03 13:23:23 EST
I checked DaveJ's x86_64 kernel and it does in fact have CONFIG_SMP set, so yes,
there is an issue.
Comment 4 John Ellson 2005-12-03 13:50:10 EST
I double checked using only download.fedora.redhat.com kernel:

kernel-2.6.14-1.1632_FC5 sees 2 cores
kernel-2.6.14-1.1735_FC5 does not.
Comment 5 Dave Jones 2005-12-03 15:54:53 EST
can you attach dmesg's from both working and not working please ?
Comment 6 John Ellson 2005-12-03 16:13:38 EST
Created attachment 121804 [details]
dmesg from 2.6.14-1.1632_FC5 - sees 2 cores
Comment 7 John Ellson 2005-12-03 16:17:28 EST
Created attachment 121805 [details]
dmesg from 2.6.14-1.1737_FC5 - sees 1 core

The OOPS is a separate problem - see bug #174188
Comment 8 John Ellson 2005-12-03 16:55:39 EST
Created attachment 121808 [details]
dmesg from 2.6.14-1.1674_FC5 - sees 2 cores
Comment 9 John Ellson 2005-12-03 16:56:58 EST
Created attachment 121809 [details]
dmesg from 2.6.14-1.1682_FC5 - sees 1 core
Comment 10 John Ellson 2005-12-04 08:10:15 EST
You didn't ask, but in case you were hoping, kernel-2.6.14-1.1739_FC5 didn't fix
this, or the oops in #174188.   
Comment 11 John Ellson 2005-12-17 13:24:50 EST
kernel-2.6.14-1.1770_FC5 and still only one cpu core recognized.
Is there any news on this bug?
Comment 12 Dave Jones 2005-12-23 14:27:21 EST
can you attach a dmesg from a kernel rev 1780 or higher ?
I changed something wrt hotplug CPUs that may affect this. (And some upstream
x86-64 specific fixes also got merged).

Comment 13 John Ellson 2005-12-23 14:33:08 EST
Created attachment 122565 [details]
dmesg from 2.6.14-1.1783_FC5 - sees 1 core
Comment 14 Dave Jones 2005-12-23 15:12:25 EST
There's no indication in the BIOS tables that it knows about the other core.
Is there an update available you can try ?

What board is this ?
Comment 15 John Ellson 2005-12-23 16:11:01 EST
Its a MSI K8N-Neo4-Platinum, purchased within the last month.

I was wondering if it was a BIOS problem, but how is it that
upto kernel-2.6.14-1-1674 the kernel was seeing 2 cores?
(see dmesg in 3rd attachment).


I'll go looking for BIOS updates...

Comment 16 John Ellson 2005-12-23 16:36:31 EST
Yes, my BIOS is old.  I have 1.3 and 1.A is the latest.

Doing an update is tough as this box has no floppy and I don't have a 
windows boot disk.    Is it really required?   I thought Linux mostly
ignored the BIOS?

-----------------------------------------
 
 
Model 	Version 	Size 	Platform 	BIOS 	BIOS Date 	Counter
K8N Neo4 Platinum (MS-7125) 	v. 1.A 	356 kb 	AMD 	Award BIOS 	11/7/2005 	
1. This is Award BIOS release
2. This BIOS fixes the following problem of the previous version:
- Supports Winbond W39V040FB BIOS ROM
3. 2005/11/07

Model 	Version 	Size 	Platform 	BIOS 	BIOS Date 	Counter
K8N Neo4 Platinum (MS-7125) 	v. 1.9 	356 kb 	AMD 	Award BIOS 	9/9/2005 	
1. This is Award BIOS release
2. This BIOS fixes the following problem of the previous version:
- Improves compatilbility problem with some USB 2.0 devices
3. 2005/09/09

Model 	Version 	Size 	Platform 	BIOS 	BIOS Date 	Counter
K8N Neo4 Platinum (MS-7125) 	v. 1.5 	356 kb 	AMD 	Award BIOS 	6/3/2005 	
1. This is Award BIOS release
2. This BIOS fixes the following problem of the previous version:
- Update CPUID.
- Update NVMM version to 4.052.08.
- Update NVPXE version 2.12.
3. 2005/06/03

Model 	Version 	Size 	Platform 	BIOS 	BIOS Date 	Counter
K8N Neo4 Platinum (MS-7125) 	v. 1.4 	361 kb 	AMD 	Award BIOS 	5/10/2005 	
1. This is Award BIOS release
2. This BIOS fixes the following problem of the previous version:
- Support AMD K8 reversion E stepping CPU.
- Update NVPXE version to 2.12.
- Update NVMM version to 4.94.
- Update SiI3114 RAID ROM version to 5.2.03.
- Update CPU ID.
3. 05/10/2005
Comment 17 John Ellson 2005-12-23 16:42:16 EST
Or perhaps the 1674 and earlier kernels didn't actually bring up two cores, but 
/proc/cpuinfo on those kernels knew about the two cores.
Comment 18 Dave Jones 2005-12-23 17:58:16 EST
The reason it showed up in /proc/cpuinfo on the older kernels is that was
showing what the maximum values were (ie, what the CPU could theoretically do),
not what was available (what the BIOS had set up).  We require the BIOS to set
up a number of things before we boot, such as configuring the APICs.

This bit of the changelog..

Support AMD K8 reversion E stepping CPU.

is what's important. Rev E were the first dual-cores.
I'm pretty convinced this will fix your problem.

The lack of floppy will be a problem though. Unless it supports booting from usb
memory stick (which some newer boards do).  You'll still need to find a bootable
DOS image though.  Aparently a lot of people have success with
http://www.freedos.org

As this is a hardware problem, there's really nothing more that I can do here.

Good luck!
Comment 19 John Ellson 2006-01-02 02:15:10 EST
This problem was fixed by updating to MSI BIOS 7125v1A.

Comment 20 Dave Jones 2006-01-02 23:42:55 EST
excellent! Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.