This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 17490 - Redhat 6.2 does not boot on AMD Athlon thunderbird/duron chips
Redhat 6.2 does not boot on AMD Athlon thunderbird/duron chips
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-14 00:16 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 12:59:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-14 00:16:50 EDT
The kernel (2.2.14) thinks that these processers are in fact Pentium 
III's, and it tries to disable the serial number.  Since Athlon 
tbirds/durons do not have serial numbers, this operation fails, there is a 
kernel panic, and the system halts.  Booting off of the rescue disk yields 
the same results.
Comment 1 Need Real Name 2000-09-15 12:59:17 EDT
i think i have the same problem.  i get a gpf 
when disabling CPUID serial number in boot on
a duron 600 (tyan 2390 board).  i can boot off
cdrom and other oses are fine.  i tried installing 
the smp and boot kernels from the cdrom to no avail...

i noticed that the cpu was running a little hot
77 - 80 C -- maybe this is just the gauge...

the CPU vender id comes up AMD on the boot 
messages and linux/arch/i386/setup.c looks like
it only trys to turn off the serial # if the
vender is intel (from 2.2.14 on kernel.org):

>       if (c->cpuid_level > 0 && c->x86_vendor == X86_VENDOR_INTEL)
>        {
>                if(c->x86_capability&(1<<18))
>                {
>                        /* Disable processor serial number on Intel Pentium III 
>                           from code by Phil Karn */ 

i'll try upgrading to 2.2.16 -- though nothing has
really changed in this bit of code in 2.2.16...
Comment 2 Need Real Name 2000-09-15 13:03:00 EDT
I figured out how to fix this problem from LILO.  At the prompt, type "linux 
x86_serial_nr=1".  This makes sure the kernel does not try to turn off the 
serial number (bad on processors that don't have them :-))

Everything should boot fine.

Note You need to log in before you can comment on or make changes to this bug.