Bug 1749024 - [3.11] Ensure minimum kernel version during upgrade
Summary: [3.11] Ensure minimum kernel version during upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Russell Teague
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks: 1749028 1749029 1751223
TreeView+ depends on / blocked
 
Reported: 2019-09-04 17:34 UTC by Brenton Leanhardt
Modified: 2021-08-05 17:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Add a check to ensure the installed kernel meets the required minimum to avoid network issues. This check is run during prerequisites, scaleup and upgrade.
Clone Of:
: 1749028 1749029 1751223 (view as bug list)
Environment:
Last Closed: 2019-09-24 08:08:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 11881 0 'None' closed Bug 1749024: Ensure minimum kernel version 2021-01-25 22:51:12 UTC
Github openshift openshift-ansible pull 11889 0 'None' closed Bug 1749024: Update minimum required kernel version 2021-01-25 22:51:12 UTC
Red Hat Product Errata RHBA-2019:2816 0 None None None 2019-09-24 08:08:17 UTC

Description Brenton Leanhardt 2019-09-04 17:34:55 UTC
Description of problem:

Many customers have been affected by Bug #1648965.  We should add a check for the appropriate kernel version as part of our upgrade preflight checks.  If it's simple enough to add to our install preflight checks we should consider that as well.

Looking at the erratas that shipped that bug fix is appears to be included in the following builds:

7.7:     kernel-3.10.0-1062.el7
7.6 EUS: kernel-3.10.0-957.27.4.el7
7.6:     kernel-3.10.0-957.27.2.el7

Comment 2 Russell Teague 2019-09-09 20:49:16 UTC
Will be submitting an update based on feedback in https://github.com/openshift/openshift-ansible/issues/11883

Comment 3 Weihua Meng 2019-09-10 09:57:52 UTC
need we follow doc or update doc for RHEL version?

Base OS: Red Hat Enterprise Linux (RHEL) 7.4 or later with the "Minimal" installation option and the latest packages from the Extras channel, or RHEL Atomic Host 7.4.5 or later.

https://docs.openshift.com/container-platform/3.11/install/prerequisites.html#hardware


in code 

      minimum_kernel_version:
        "7.6": "3.10.0-957.27.2.el7"	        "7.6": "3.10.0-957.27.2"
        "7.7": "3.10.0-1062.el7"	        "7.7": "3.10.0-1062"

Comment 4 Johnny Liu 2019-09-11 01:06:39 UTC
Seem like this PR introduce some issues:
TASK [Ensure minimum kernel version] *******************************************
Tuesday 10 September 2019  16:51:35 +0800 (0:00:00.628)       0:00:17.824 ***** 
fatal: [qe-sreg-3criogcemaster-etcd-1.0910-lqe.qe.rhcloud.com]: FAILED! => {"changed": false, "msg": "The installed kernel version does not meet the required minimum for RHEL 7.7.\nPlease update the kernel before continuing.\nMinimum Kernel Version: 3.10.0-1062.el7\nInstalled Kernel Version: 3.10.0-1062.1.1.el7.x86_64\nReference: https://bugzilla.redhat.com/show_bug.cgi?id=1749024\n"}
fatal: [qe-sreg-3criogcenode-registry-router-1.0910-lqe.qe.rhcloud.com]: FAILED! => {"changed": false, "msg": "The installed kernel version does not meet the required minimum for RHEL 7.7.\nPlease update the kernel before continuing.\nMinimum Kernel Version: 3.10.0-1062.el7\nInstalled Kernel Version: 3.10.0-1062.1.1.el7.x86_64\nReference: https://bugzilla.redhat.com/show_bug.cgi?id=1749024\n"}
fatal: [qe-sreg-3criogcenode-1.0910-lqe.qe.rhcloud.com]: FAILED! => {"changed": false, "msg": "The installed kernel version does not meet the required minimum for RHEL 7.7.\nPlease update the kernel before continuing.\nMinimum Kernel Version: 3.10.0-1062.el7\nInstalled Kernel Version: 3.10.0-1062.1.1.el7.x86_64\nReference: https://bugzilla.redhat.com/show_bug.cgi?id=1749024\n"}
fatal: [qe-sreg-3criogcenode-2.0910-lqe.qe.rhcloud.com]: FAILED! => {"changed": false, "msg": "The installed kernel version does not meet the required minimum for RHEL 7.7.\nPlease update the kernel before continuing.\nMinimum Kernel Version: 3.10.0-1062.el7\nInstalled Kernel Version: 3.10.0-1062.1.1.el7.x86_64\nReference: https://bugzilla.redhat.com/show_bug.cgi?id=1749024\n"}

Actually 3.10.0-1062.1.1.el7.x86_64 > 3.10.0-1062.el7, so it shouldn't fail here.

Comment 5 Weihua Meng 2019-09-11 03:17:29 UTC
Fixed in openshift-ansible-3.11.145-1.git.0.61bc1df.el7

kernel 3.10.0-1062.1.1.el7.x86_64 can be installed without error.


for kernel requirement, can report correctly
fatal: [ec2-54-210-41-10.compute-1.amazonaws.com]: FAILED! => {"changed": false, "msg": "The installed kernel version does not meet the required minimum for RHEL 7.6.\nPlease update the kernel before continuing.\nMinimum Kernel Version: 3.10.0-957.27.2\nInstalled Kernel Version: 3.10.0-931.el7.x86_64\nReference: https://bugzilla.redhat.com/show_bug.cgi?id=1749024\n"}

Comment 7 errata-xmlrpc 2019-09-24 08:08:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2816


Note You need to log in before you can comment on or make changes to this bug.