Bug 1749129 - Timeout during undercloud installation on _create_default_plan Mistral action
Summary: Timeout during undercloud installation on _create_default_plan Mistral action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Rabi Mishra
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-05 01:09 UTC by Matt Parkinson
Modified: 2019-11-07 14:02 UTC (History)
3 users (show)

Fixed In Version: instack-undercloud-8.4.7-13.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:02:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 680292 None MERGED Bump default plan creation timeout 2020-04-07 05:29:38 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:37 UTC

Description Matt Parkinson 2019-09-05 01:09:21 UTC
Description of problem:

The hardcoded timeout for Mistral step "_create_default_plan" of 360 seconds is being reached in our development/test environment when installing the undercloud. On the second attempt, the undercloud installation completes.

This appears to have been addressed in https://bugzilla.redhat.com/show_bug.cgi?id=1619704 by increasing the timeout to 20 minutes, however I do not see any changes in "instack_undercloud/undercloud.py". Both the packaged Python library and the upstream stable/queens branch show a timeout of 360 seconds.

We need the timeout increased, or better yet exposed as a hiera override we can set in the undercloud config.

Version-Release number of selected component (if applicable):

# rpm -q instack-undercloud
instack-undercloud-8.4.7-10.el7ost.noarch

# cat /etc/rhosp-release 
Red Hat OpenStack Platform release 13.0.7 (Queens)

How reproducible:

Intermittent - need an under-performing undercloud

Steps to Reproduce:
1.
2.
3.

Actual results:

2019-09-04 04:44:06,680 ERROR: TIMEOUT waiting for execution b037a8b9-33ee-4866-8c3f-e9374928925e to finish. State: RUNNING
2019-09-04 04:44:06,680 DEBUG: An exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2438, in install
    _post_config(instack_env, upgrade)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2130, in _post_config
    _post_config_mistral(instack_env, mistral, swift)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2066, in _post_config_mistral
    _create_default_plan(mistral, plans)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2008, in _create_default_plan
    fail_on_error=True)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1916, in _wait_for_mistral_execution
    raise RuntimeError(error_message)
RuntimeError: TIMEOUT waiting for execution b037a8b9-33ee-4866-8c3f-e9374928925e to finish. State: RUNNING
2019-09-04 04:44:06,681 ERROR: 
#############################################################################
Undercloud install failed.

Reason: TIMEOUT waiting for execution b037a8b9-33ee-4866-8c3f-e9374928925e to finish. State: RUNNING

See the previous output for details about what went wrong.  The full install
log can be found at /home/stack/.instack/install-undercloud.log.

#############################################################################

Expected results:

Successful undercloud install, with either increased or adjustable timeout values

Additional info:

Comment 9 errata-xmlrpc 2019-11-07 14:02:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.