Bug 174917 - Rhythmbox playback is choppy
Rhythmbox playback is choppy
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 22:32 EST by Dennis Jacobfeuerborn
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 11:24:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2005-12-03 22:32:51 EST
Rhythmbox playback is choppy when I try to play a file. Xmms playback works fine.
The version I'm using is rhythmbox-0.9.1-1.
Comment 1 Thomas J. Baker 2006-01-04 16:28:59 EST
I'm getting the same thing with rhythmbox-0.9.2-4. It's probably an alsa problem
but we gotta start somewhere. My sound card is using snd_cs46xx. Xmms also works
fine so I'm guessing alsa. As an aside, is rendevous type auto detection of
music shares supposed to work? Maybe I should file another bug?
Comment 2 Dennis Jacobfeuerborn 2006-01-05 18:28:44 EST
I use the alsa output plugin with Xmms so if it's really the backend then my
money would be on gstreamer. Unfortunately debugging isn't easy because:

a) It's extremely hard to understand which configuration Fedora is running due
to the alsa configuration mess. Something like "/proc/asound/config" would be
nice that contains the actual running configuration. Right now I can't even
figure out if I'm running dmix or not.

b) There is no obvious way to configure gstreamer in Fedora so it's not possible
to switch e.g. between alsa and oss for debugging purposes.

c) Rhythmbox does not provide any audio output configuration options either
which wouldn't be a problem if b) was fixed.
Comment 3 Thomas J. Baker 2006-01-06 08:22:40 EST
My bad. I meant gstreamer as my xmms is using alsa too. Under gnome, you can go
to Preferences->More Preferences->Multimedia Systems Selector to change what
gstreamer users for input and output. I'll try that later today.
Comment 4 John (J5) Palmieri 2006-01-06 10:52:00 EST
We are moving to gstreamer 0.10 with rythmbox.  It should be in over the
weekend.  Please try again when you get the update.
Comment 5 Thomas J. Baker 2006-01-06 11:18:53 EST
I've got gstreamer10 installed but I don't know if rhythmbox is using it yet.
But, using the MSS pref and switching the output to esd, rhythmbox works fine. 
Comment 6 John (J5) Palmieri 2006-01-06 11:35:08 EST
you will need to uninstall gstreamer10 as core now contains gstreamer-0.10 which
will conflict (gstreamer10 was never in any offical repository).  Only the CVS
version of rythmbox can take advantage of gstreamer 0.10 and it needs to be
compiled in.
Comment 7 Thomas J. Baker 2006-01-06 13:23:54 EST
I only have devel and extras-devel enabled. Actually they are what you're saying:

katratzi> rpm -qa | grep gstreamer
gstreamer-plugins-0.8.11-1.1
gstreamer08-plugins-0.8.11-2
gstreamer08-0.8.11-2
gstreamer-0.10.0-1
gstreamer-tools-0.10.0-1
katratzi>

Comment 8 John (J5) Palmieri 2006-01-06 13:49:24 EST
Cool, I'm compiling rythmbox with gstreamer 0.10 support today.
Comment 9 Dennis Jacobfeuerborn 2006-01-07 09:15:35 EST
I've tried rhythmbox with gstreamer10 since mid-december with little success but
a new CVS checkout with the fedora gstreamer-0.10 packages seems to work fine.
There are some other issues regarding rhythmbox itself but these have nothing to
do with this bug and I'll carry them over the the rhythmbox mailinglist. I think
this bug can be marked as fixed.
Comment 10 Bastien Nocera 2007-01-30 11:24:02 EST
Thanks for the notice, closing this bug report.

Note You need to log in before you can comment on or make changes to this bug.