Bug 174921 - openvpn needs updating to 2.1-beta7 to fix redirect-gateway config file directive
Summary: openvpn needs updating to 2.1-beta7 to fix redirect-gateway config file direc...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openvpn
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL: http://openvpn.net/changelog-beta.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-04 08:14 UTC by Stephen Warren
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-12-04 21:39:14 UTC


Attachments (Terms of Use)

Description Stephen Warren 2005-12-04 08:14:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Config file directive "redirect-gateway" doesn't work because of an upstream package bug. Looking at the changelog, it's fixed in the next beta release.


Version-Release number of selected component (if applicable):
openvpn-2.1-0.2.beta6.fc5

How reproducible:
Always

Steps to Reproduce:
1. Edit openvpn's config file, add "redirect-gateway" option there
2. service start openvpn
3. less /var/log/messages
4. Observe text "NOTE: unable to redirect default gateway -- Cannot read current default gateway from system"

  

Actual Results:  Error message displayed in syslog.

Default gateway is left unchanged on the system after the VPN is brought up.

Expected Results:  Default gateway should be set to the gateway value pushed by the VPN server

Additional info:

openvpn upstream changelog indicates it's already fixed in the next beta:

Fixed bug in Linux get_default_gateway function
introduced in 2.0.4, which would cause redirect-gateway
on Linux clients to fail.

Comment 1 Steven Pritchard 2005-12-04 21:39:14 UTC
Apparently when I updated to 2.1-beta7 on November 18, I forgot to request a build.

Sorry for the inconvenience.

Comment 2 Stephen Warren 2005-12-06 05:18:53 UTC
Out of curiosity, how long do the builds take - I assume it's some kind of
automated queue?

Not trying to bug you though.


Comment 3 Steven Pritchard 2005-12-06 15:35:42 UTC
The build failed due to dependency breakage in rawhide.  I just requeued the
build.  Hopefully it will go well this time.


Note You need to log in before you can comment on or make changes to this bug.