Bug 174921 - openvpn needs updating to 2.1-beta7 to fix redirect-gateway config file directive
openvpn needs updating to 2.1-beta7 to fix redirect-gateway config file direc...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openvpn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
http://openvpn.net/changelog-beta.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 03:14 EST by Stephen Warren
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1-0.3.beta7.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-04 16:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2005-12-04 03:14:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Config file directive "redirect-gateway" doesn't work because of an upstream package bug. Looking at the changelog, it's fixed in the next beta release.


Version-Release number of selected component (if applicable):
openvpn-2.1-0.2.beta6.fc5

How reproducible:
Always

Steps to Reproduce:
1. Edit openvpn's config file, add "redirect-gateway" option there
2. service start openvpn
3. less /var/log/messages
4. Observe text "NOTE: unable to redirect default gateway -- Cannot read current default gateway from system"

  

Actual Results:  Error message displayed in syslog.

Default gateway is left unchanged on the system after the VPN is brought up.

Expected Results:  Default gateway should be set to the gateway value pushed by the VPN server

Additional info:

openvpn upstream changelog indicates it's already fixed in the next beta:

Fixed bug in Linux get_default_gateway function
introduced in 2.0.4, which would cause redirect-gateway
on Linux clients to fail.
Comment 1 Steven Pritchard 2005-12-04 16:39:14 EST
Apparently when I updated to 2.1-beta7 on November 18, I forgot to request a build.

Sorry for the inconvenience.
Comment 2 Stephen Warren 2005-12-06 00:18:53 EST
Out of curiosity, how long do the builds take - I assume it's some kind of
automated queue?

Not trying to bug you though.
Comment 3 Steven Pritchard 2005-12-06 10:35:42 EST
The build failed due to dependency breakage in rawhide.  I just requeued the
build.  Hopefully it will go well this time.

Note You need to log in before you can comment on or make changes to this bug.