Bug 1749236 - etime displayed has an order of magnitude 10 times smaller than it should be
Summary: etime displayed has an order of magnitude 10 times smaller than it should be
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.7
Hardware: Unspecified
OS: All
high
medium
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: RHDS QE
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1801701
TreeView+ depends on / blocked
 
Reported: 2019-09-05 08:03 UTC by sgouvern
Modified: 2020-03-31 19:46 UTC (History)
8 users (show)

Fixed In Version: 389-ds-base-1.3.10.1-3.el7
Doc Type: Bug Fix
Doc Text:
.Directory Server now logs the correct `etime` value in the access log Previously, Directory Server incorrectly formatted the `etime` field in the `/var/log/dirsrv/slapd-<instance_name>/access` log file. As a consequence, the time value in nanoseconds was 10 times lower than the actual value. This update fixes the problem. As a result, Directory Server now logs the correct nanosecond value in the `etime` field.
Clone Of:
: 1801701 (view as bug list)
Environment:
Last Closed: 2020-03-31 19:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1064 None None None 2020-03-31 19:46:55 UTC

Description sgouvern 2019-09-05 08:03:05 UTC
Description of problem:

In the access log, the etime displayed seems to always be 10 times smaller than it should be.

This error can systematically be seen 


Version-Release number of selected component (if applicable):
seen on both 389-ds-base 1.3.10.1-1.el7 and 389-ds-base-1.3.9.1-8.el7


How reproducible:

Always

Steps to Reproduce:
1.perform an ldap operation
2.open the access log
3.for example :

[03/Sep/2019:04:52:09.428566825 -0400] conn=24 op=1 SRCH base="dc=example,dc=com" scope=2 filter="(objectClass=*)" attrs=ALL
[03/Sep/2019:04:52:09.626959338 -0400] conn=24 op=1 RESULT err=0 tag=101 nentries=11161 etime=0.0198511652 notes=A

Actual results:

etime=0.0198511652


Expected results:

should be 0.198511652


Additional info:

Comment 2 mreynolds 2019-10-16 20:52:16 UTC
Upstream ticket:
https://pagure.io/389-ds-base/issue/50655

Comment 3 mreynolds 2019-10-16 23:36:29 UTC
Fixed upstream

Comment 12 errata-xmlrpc 2020-03-31 19:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1064


Note You need to log in before you can comment on or make changes to this bug.