Bug 174924 - Missing/bloating -devel dependencies
Missing/bloating -devel dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apr-util (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 04:18 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 10:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-12-04 04:18:52 EST
The *.la file, apu-1-config, and the pkgconfig file all refer to -lpq -lsqlite3,
but the corresponding postgresql-devel and sqlite-devel dependencies are missing
from apr-util-devel.

On the other hand, now that static libs are not included, maybe these are pure
dependent app bloaters and should be pruned (along with a few other library
dependencies) from *.la, *.pc and *-config instead?
Comment 1 Ville Skyttä 2005-12-04 04:38:46 EST
add e2fsprogs-devel to the list (for -luuid).

And Requires: pkgconfig would be nice in -devel too as it installs files into
pkgconfig-owned dir.
Comment 2 Ville Skyttä 2005-12-04 04:47:28 EST
Oops, -luuid/e2fsprogs-devel should be taken care of in apr-devel.
Comment 3 Joe Orton 2005-12-06 10:09:44 EST
I've trimmed -lpq -lsqlite3 from the exported dependency_libs etc, thanks for
report.
Comment 4 Ville Skyttä 2005-12-06 14:56:10 EST
Thanks.  While at it, would it be possible to trim the expat-devel dependency
the same way?  db4-devel and openldap-devel apparently cannot because of some
#includes in shipped apr-util-devel headers.  (Reopened for comments.)
Comment 5 Joe Orton 2005-12-07 10:59:28 EST
No, I think not; the expat dependency is "exported" whereas the others are not.
 (subversion and httpd both expat via the apr-util dependency).  So it's correct
that the other applications pick up an appropriate DT_NEEDED field for libexpat. 

Note You need to log in before you can comment on or make changes to this bug.