Bug 174926 - wrong %{_lib} in the x86_64 version
wrong %{_lib} in the x86_64 version
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 06:20 EST by Thomas Antony
Modified: 2008-04-23 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 06:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Antony 2005-12-04 06:20:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Since all 64 bit libs should install to lib64, the cyrus-imapd rpm should install to /usr/lib64/cyrus-imapd instead of /usr/lib/cyrus.

[thomas@ws01 ~]$ file /usr/lib/cyrus-imapd/imapd
/usr/lib/cyrus-imapd/imapd: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for GNU/Linux 2.4.0, dynamically linked (uses shared libs), for GNU/Linux 2.4.0, stripped

Version-Release number of selected component (if applicable):
cyrus-imapd-2.2.12-6.fc4

How reproducible:
Always

Steps to Reproduce:
1. install cyrus-imapd

  

Additional info:
Comment 1 John Dennis 2006-02-28 17:05:47 EST
Did a little investigation, many parts of the spec file do use %{_lib} which
made this a little confusing, I think the problem arises with this line in the
spec file:

%define _cyrexecdir %{_exec_prefix}/lib/%{name}

which I think should be changed to:

%define _cyrexecdir %{_libdir}/%{name}

However, locating the executables in /usr/lib64/cyrus-imapd rather than the
conventional /usr/lib/cyrus-imapd, while technically correct will confuse a lot
of scripts and add-on utilites which expect to find it in the later location.

At the moment I'm reluctant to make the change without a clear understanding of
how many things are going to break, this needs some more investigation.
Comment 2 Thomas Antony 2006-06-17 12:33:29 EDT
I noticed that this is still not fixed with cyrus-imapd-2.3.1-2.6.fc5
Please find a resolution in the near future and fix this problem.
Comment 3 Kostas Georgiou 2007-02-22 09:30:59 EST
The files under /usr/lib/cyrus-imapd are not libraries so they don't belong
under /usr/lib64. 
Comment 4 Tomas Janousek 2008-04-22 09:01:46 EDT
Well, in RHEL-4, the files are in /usr/lib64 and since then, someone has moved
them to /usr/lib, for a reason I don't know. If they're not libraries, they
probably belong to /usr/libexec anyway. But I had decided to leave this decision
to a reviewer and I'm therefore closing this one. If you believe the files
should be somewhere else, make a note of it in the review bug, please.
Comment 5 Thomas Antony 2008-04-22 18:25:07 EDT
There are only executables, perl and bash script and no libs in
/usr/lib/cyrus-imapd, so this is defintily the wrong place.
Won't fix isn't a solution and the right direction.
What does the Fedora packaging rules say?

Comment 6 Tomas Janousek 2008-04-23 06:24:32 EDT
> If you believe the files should be somewhere else, make a note of it in the
review bug, please.

Note You need to log in before you can comment on or make changes to this bug.