Bug 174931 - Evolution evolution-2.4.1-8 is not interpreting properly non-ascii imap folders
Evolution evolution-2.4.1-8 is not interpreting properly non-ascii imap folders
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-04 09:22 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-data-server-1.5.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 15:35:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installed package changes (6.96 KB, application/x-bzip)
2005-12-05 16:46 EST, Nicolas Mailhot
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 323106 None None None Never

  None (edit)
Description Nicolas Mailhot 2005-12-04 09:22:40 EST
Description of problem:

Starting with evolution-2.4.1-8 non-ascii imap folders are displayed in the tree
view with non-interpreted UTF-8 names ( for example é instead of é)

Of course when you click on the forlder evo can't find it on the imap server

It worked fine before. It's still working fine with the same imap server
accessed by other imap clients

Version-Release number of selected component (if applicable):

evolution-2.4.1-8

How reproducible:

always
Comment 1 Dave Malcolm 2005-12-05 15:39:18 EST
Thanks for this bug report.

What was the last version of evolution that this worked with for you?
Any idea which version of evolution-data-server this was working/not working with?
Thanks.
Comment 2 Nicolas Mailhot 2005-12-05 16:42:32 EST
I only noticed it with yesterday's rawhide sync
Now because of the dbus update, lots of stuff got stuck for several days so it
was a big one.

I'm pretty sure evolution-2.4.1-7 was okay, today's evo is evolution-2.4.2-2,
not sure of the intermediate versions

Problem is easy to test - just use another imap client (thunderbird...) to
create a folder with non-ascii (accented latin, euro, cyrillic, whatever)
letters on the server, then ask evo to show folders it can subscribe to
Comment 3 Nicolas Mailhot 2005-12-05 16:46:51 EST
Created attachment 121873 [details]
installed package changes

Packages before and after the problem.

I'm being conservative - I had a few minor yum syncs that weren't caught in the
logs, for example evo is now at 2.4.2-2 but I logged the problem with evo
2.4.1-8

I'm fairly sure the first state was sane though
Comment 4 Nicolas Mailhot 2005-12-05 16:50:15 EST
Also don't know if it's related but I can freeze gnome fairly easily just by
doing stuff in evo now.

Non-gnome apps are fine (firefox, thunderbird) gnome apps (panel included) stop
responding, I need to go to the console and kill gnome-session to recover it
Comment 5 Nicolas Mailhot 2005-12-12 15:35:04 EST
Still there with :
evolution-webcal-2.4.1-1.1
evolution-2.5.2-1.1
evolution-data-server-1.5.2-1.1

I know this bug seems harmless - just use ascii folder names you'll tell me

However many default folders ("Sent" for example) have problem names in other
languages, so if this is not fixed before the next FC5 test release it's going
to hit an awful number of users.
Comment 6 Nicolas Mailhot 2005-12-21 15:46:09 EST
Still there with :
evolution-data-server-1.5.3-2
evolution-2.5.3-1
evolution-webcal-2.4.1-2
Comment 7 Dave Malcolm 2005-12-21 16:17:47 EST
Looks like a duplicate of this upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=323106

Looks like this is fixed in upstream evolution-data-server CVS, so the fix
should make it into 1.5.4
Comment 8 Dave Malcolm 2006-01-05 15:00:24 EST
Should be fixed now in rawhide.  Please can you test this and verify that it's
fixed:
evolution-data-server-1.5.4-1
Comment 9 Nicolas Mailhot 2006-01-05 15:35:46 EST
I can confirm the fix
Thank you very much

Note You need to log in before you can comment on or make changes to this bug.