Bug 17494 - RPM_OPT_FLAGS not honored by ppp compilation
Summary: RPM_OPT_FLAGS not honored by ppp compilation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ppp   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-14 09:44 UTC by Moritz Barsnick
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:24:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Optimization variable adjustment to enable RPM_OPT_FLAGS handling (1.79 KB, patch)
2000-09-14 09:51 UTC, Moritz Barsnick
no flags Details | Diff

Description Moritz Barsnick 2000-09-14 09:44:50 UTC
ppp (latest: ppp-2.4.0b2-2) does not honor the RPM_OPT_FLAGS. There is a
slight modification in ppp-2.3.11-make.patch which adds "$(RPM_OPT_FLAGS)"
to COPTS in ppp-2.3.10/pppstats/Makefile.linux, but this is not the way to
go anyway. Rather just call 'make' as 'make COPTS="$RPM_OPT_FLAGS'.
Furthermore, there are many more Makefiles in the ppp package.

I am providing a patch which moves all the CC optimization parameters into
"COPTS" variables, and allows for calling 'make COPTS="$RPM_OPT_FLAGS'.
Tested.

(Other observations: ppp-2.3.11-make.patch is actually against 2.3.10  
:->)

Comment 1 Moritz Barsnick 2000-09-14 09:51:54 UTC
Created attachment 3423 [details]
Optimization variable adjustment to enable RPM_OPT_FLAGS handling

Comment 2 Moritz Barsnick 2000-09-14 09:55:35 UTC
Sorry, meant to say ppp-2.3.11-7. Patch applies against 2.4.0, which is current,
and works with older and newer kernels. (To be tested of course. :->) The patch
applies nicely on 2.3.11 as well.

Comment 3 Thomas Woerner 2004-08-13 09:24:05 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.