Bug 1749433 - enabled zoom stops sending mouse button events
Summary: enabled zoom stops sending mouse button events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: BetaFreezeException, F31BetaFreezeException F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-05 15:30 UTC by Chris Murphy
Modified: 2019-10-16 19:43 UTC (History)
15 users (show)

Fixed In Version: mutter-3.34.1-4.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 19:43:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-shell/merge_requests/754 None None None 2019-10-10 18:24:24 UTC
GNOME Gitlab GNOME/mutter/issues/826 None None None 2019-09-24 00:28:56 UTC
GNOME Gitlab GNOME/mutter/merge_requests/832 None None None 2019-10-10 18:24:24 UTC

Description Chris Murphy 2019-09-05 15:30:05 UTC
Description of problem:

The on/off switch worked once to turn it on, but now I can't turn it off (nothing happens).

Version-Release number of selected component (if applicable):
gnome-control-center-3.33.90-1.fc31.x86_64

How reproducible:
1 for 1

Steps to Reproduce:
1. Settings>Universal Access>Zoom
2. Change "Magnifier Position" to "Follow mouse cursor
3. Click switch to enable

Actual results:

I get zoom, and it follows mouse pointer movement around as expected. But now when I click on the same switch I used to enable, it will not disable. I can switch windows: I have a nautilus window I can switch to and from by clicking on it and on g-c-c but I cannot close the Zoom Options window, and I can't disable zoom. Nor can I change any of the options in it, to say go to magnification 1.00 as a work around.

Expected results:

All the fields and buttons should still work and be clickable, and I should be able to turn it off.

Additional info:

Comment 1 Chris Murphy 2019-09-05 15:33:16 UTC
This is a regression from gnome-control-center-3.32.2-1.fc30.x86_64 where it works as expected.

Comment 2 Fedora Blocker Bugs Application 2019-09-05 15:33:57 UTC
Proposed as a Blocker for 31-final by Fedora user chrismurphy using the blocker tracking app because:

 All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use.

Comment 3 Kalev Lember 2019-09-06 10:03:30 UTC
Any chance you could file this upstream, please, in addition to this ticket? https://gitlab.gnome.org/GNOME/gnome-control-center Thanks.

Comment 4 Michael Catanzaro 2019-09-08 16:02:26 UTC
Well I agree this is bad, but it seems more like freeze exception material than a release blocker.

Comment 5 Adam Williamson 2019-09-09 17:11:50 UTC
does it reset if you reboot or log out?

Comment 6 Chris Murphy 2019-09-09 18:03:21 UTC
Nope. And in fact on next login with zoom still enabled, the mouse pointer isn't visible in any applications, only when mousing over Shell objects.

Comment 7 Chris Murphy 2019-09-09 18:06:21 UTC
It's not a beta blocker but it's definitely a final blocker - there's no obvious work around for it once you run into it. I've been doing

[chris@flap ~]$ scp .config/dconf/user chris@fmac.local:~/.config/dconf/user

Comment 8 Geoffrey Marr 2019-09-09 19:58:10 UTC
Discussed during the 2019-09-09 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-09/f31-blocker-review.2019-09-09-16.00.txt

Comment 9 Adam Williamson 2019-09-10 21:21:47 UTC
Seems a bit of an oversight that we didn't grant this a Beta FE - we probably should...nominating it.

Comment 10 Chris Murphy 2019-09-10 21:23:37 UTC
+1

Comment 11 Michael Catanzaro 2019-09-13 23:26:54 UTC
gnome-control-center maintainer (Georges) suspects mutter.

Comment 12 Florian Müllner 2019-09-20 23:17:35 UTC
(In reply to Michael Catanzaro from comment #11)
> gnome-control-center maintainer (Georges) suspects mutter.

That looks indeed likely.

I can reproduce the problem, and the issue seems to be that no application receives any pointer events when the magnifier is enabled. Interacting with the shell works as expected[0], and so do keyboard events in applications[1].

[0] including the switch in the top bar's "universal access" menu to turn the magnifier off
[1] including the zoom switch in control center, for example with <alt>z

Comment 13 Adam Williamson 2019-10-10 18:24:24 UTC
There's a pair of MRs upstream that are intended to fix this (though they need rebasing, I think the author wrote them to a stale local checkout or something):

https://gitlab.gnome.org/GNOME/mutter/merge_requests/832
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/754

setting POST.

Comment 14 Fedora Update System 2019-10-12 16:31:24 UTC
FEDORA-2019-af6c89afe8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 15 Chris Murphy 2019-10-12 17:55:24 UTC
I installed these from the update and rebooted, and the problem still happens.
gnome-shell-3.34.1-2.fc31.x86_64
mutter-3.34.1-2.fc31.x86_64

Comment 16 Fedora Update System 2019-10-13 00:56:44 UTC
gnome-shell-3.34.1-2.fc31, mutter-3.34.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-af6c89afe8

Comment 17 Kamil Páral 2019-10-14 11:49:53 UTC
gnome-shell-3.34.1-2.fc31.x86_64
mutter-3.34.1-3.fc31.x86_64

This fixes a very small part of the story. If you follow the reproducer from comment 0, you can now toggle the zoom on and then off. However, the feature overall is still utterly broken. Once you click on any drop-down menu (for example the one after "Screen part:" in the Zoom dialog), you mouse stops sending any events once again. You can only fix it by unfocusing the drop-down menu using keyboard (e.g. using Tab key). If you use Activities button or the Win key to switch windows, again your mouse stops sending button events, and it can be again fixed by hitting Tab. The same happens when you try to use the app global menu. The same happens when you try to open up Nautilus hamburger menu. (Tested in a VM).

Comment 18 František Zatloukal 2019-10-14 12:15:50 UTC
Kamil, it seems it might be fixed by https://gitlab.gnome.org/verdre/gnome-shell/commit/d4e9d8cc28a43ee07ee609fccc5e6af173c7aa9b as mentioned in the upstream issue. I am working on test build right now.

Comment 19 František Zatloukal 2019-10-14 13:08:57 UTC
Okay, so, applying updated mutter PR832 solved the issue for me (if I didn't overlook anything). The commit I've mentioned in Comment 18 is wrong (this is how it ends when you have ton of different GNOME gitlab pages opened.)

Comment 20 Adam Williamson 2019-10-14 14:56:17 UTC
Thanks, I will update the update (or we'll push it stable and I'll send a new one).

Comment 21 Fedora Update System 2019-10-14 15:42:25 UTC
FEDORA-2019-cde227408b has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cde227408b

Comment 22 Kamil Páral 2019-10-14 17:20:38 UTC
(In reply to Fedora Update System from comment #21)
> FEDORA-2019-cde227408b has been submitted as an update to Fedora 31.
> https://bodhi.fedoraproject.org/updates/FEDORA-2019-cde227408b

This seems to work great now.

Comment 23 Fedora Update System 2019-10-15 15:28:00 UTC
mutter-3.34.1-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cde227408b

Comment 24 Fedora Update System 2019-10-16 19:43:17 UTC
mutter-3.34.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.