Bug 174945 - initrd says "Unable to access resume device"
initrd says "Unable to access resume device"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 14:05 EST by Stephen Warren
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 18:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2005-12-04 14:05:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
When booting, the initrd runs, and prints out these messages:

...
  Reading all physical volumes.  This may take a while...
cdrom: open failed
  Found volume group  "vg0" using metadata type lvm2.
  1 logical volume(s) in volume group "vg0" now active
label SWAP-sda6 not found
Unable to access resume device (LABEL=SWAP-sda6)
...


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1735_FC5 mkinitrd-5.0.10-1

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel

Notes: Installed fc5test1 from CDs. It installed the SMP kernel. I then did a "yum install kernel" to get the non-SMP kernel, and am booting that.

Looking at the initrd, there's a line in the /init script that says:

resume SWAP-sda6

I assume that's where the problem comes from 

Actual Results:  An error message is displayed about not being able to find the label.

Expected Results:  Error message shouldn't be printed


Additional info:

FYI, no functionality appears to be lost for me (although I haven't tried suspend/resume - I assume that's broken)

I can do this once booted:
swapoff /dev/sda6
swapon LABEL=SWAP-sda6

so I know the label is there. Also, a "dd|od -a" on the partition shows the label text.

The system is a Dell 9300. It has a SATA HDD (and ATA DVD drive). To install, I shrunk the NTFS partition they installed, and put all the Linux partitions into an extended partition:

[root@esk initrd]# sfdisk -uS -l /dev/sda

Disk /dev/sda: 12161 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1            63     96389      96327  de  Dell Utility
/dev/sda2         96390  39158890   39062501   7  HPFS/NTFS
/dev/sda3     185631075 195366464    9735390  db  CP/M / CTOS / ...
                start: (c,h,s) expected (1023,254,63) found (1023,0,1)
/dev/sda4   *  39166470 185631074  146464605   5  Extended
/dev/sda5      39166533  39375314     208782  83  Linux
/dev/sda6      39375378  42524054    3148677  82  Linux swap / Solaris
/dev/sda7      42524118 185631074  143106957  8e  Linux LVM
Comment 1 Stephen Warren 2005-12-04 14:07:21 EST
Oops. The line in /init on the initrd really says this:

resume LABEL=SWAP-sda6
Comment 2 Stephen Warren 2005-12-06 14:58:24 EST
This seems to be fixed with the latest devel updates - I don't see the error
message any more.

Note You need to log in before you can comment on or make changes to this bug.