Bug 1749469 - discrepancy between representation of events in web ui (OCP Console) and rest of the Openshift
Summary: discrepancy between representation of events in web ui (OCP Console) and rest...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1804116 1804118
TreeView+ depends on / blocked
 
Reported: 2019-09-05 17:18 UTC by Martin Bukatovic
Modified: 2020-05-04 11:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously events in Console were classified as Info or Error type which was inconsistent with CLI and k8s terminology. The classification was changed to Normal and Warning to align with CLI/K8s.
Clone Of:
: 1804116 1804118 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of events page in OCP Console (169.85 KB, image/png)
2019-09-05 17:18 UTC, Martin Bukatovic
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3642 0 'None' closed Bug 1749469: Align event types with k8s 2020-05-04 06:26:26 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:14:08 UTC

Description Martin Bukatovic 2019-09-05 17:18:09 UTC
Created attachment 1612060 [details]
screenshot of events page in OCP Console

Description of problem
======================

There is slight discrepancy between representation of events in web ui (OCP
Console) and rest of the Openshift (command line, yamls, ...).

If you consider this to be done on purpose, feel free to close this bug and
create doc bugs suggesting appropriate enhancements in the documentation.

Version-Release number of selected component
============================================

cluster channel: stable-4.2
cluster version: 4.2.0-0.nightly-2019-09-04-142146
cluster image: registry.svc.ci.openshift.org/ocp/release@sha256:179c6515ec95eba3187120f93f60a102fd34223e57b208906b56bfbf91304f6a

How reproducible
================

1/1

Steps to Reproduce
==================

1. Go to Events page in OCP Console and see event categories there
2. Do the same via REST API or oc command line tool

Actual results
==============

OCP Console (web ui) classifies events into 2 groups:

- Info category
- Error category

On the other hand oc (openshift command line tool) and other places (such as
yaml representation of k8s object), events are classified into:

- Normal type
- Warning type

Error and Warning are usually considered to describe different log levels, so
that the urgency conveyed in the web ui differs a bit compared to the command
line version of the same.

Expected results
================

The event representation is either aligned in both places or explained in the
docs, if there is some reason for this arrangement.

Additional info
===============

This looks like know behavior, but it seems not to be officially explained
nor documented properly.

Full list of event types
------------------------

K8s seems to recognize just Normal and Warning event types:

```
$ find . -name event.go | xargs grep -i warn                                    
./staging/src/k8s.io/client-go/tools/record/event.go:   // 'type' of this event, and can be one of Normal, Warning. New types could be added in future
```

While in the OCP Console (web ui), one sees the full list of Categories (Info,
Error), this is not obvious in the command line output (eg. via `oc get
events`), so at first sight, one could be puzzled whether
the disrepancy is about mapping names or missing event type somewhere.

Related documentation
---------------------

This problem is even visible in the docs:

https://docs.openshift.com/container-platform/4.1/nodes/clusters/nodes-containers-events.html

But there is no:

- Explanation of the discrepancy between event representation in CLI and OCP
  Console, even though the doc describes both.

- Full list of event types (or categories in OCP Console sense) with full
  description, even though there is such list for event "reasons" (such as
  FailedUnMount, FailedMapVolume, ...).

Comment 2 Yadan Pei 2019-12-16 06:41:21 UTC
Now Events are filtered by type 'Normal' and 'Warning' on Home -> Events page

Also events Type instead of Reason is used to determine whether it's Normal or Warning

1. Create an app and change BC source uri to invalid, create a build
$ oc get events
......
3m35s       Normal   Created             pod/perl-2-build               Created container git-clone
3m35s       Normal   Started             pod/perl-2-build               Started container git-clone
3m34s       Normal   BuildStarted        build/perl-2                   Build yapei1/perl-2 is now running
3m29s       Normal   BuildFailed         build/perl-2                   Build yapei1/perl-2 failed
3m43s       Normal   DeploymentCreated   deploymentconfig/perl          Created new replication controller "perl-1" for version 1

2. Create a standalone pod with invalid source image, take this file as example https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/busybox-pod.yaml, pod will failed to start
$ oc describe pod my-pod
.....
Events:
  Type     Reason     Age                      From                                                Message
  ----     ------     ----                     ----                                                -------
  Normal   Scheduled  <unknown>                default-scheduler                                   Successfully assigned yapei1/my-pod to ip-10-0-134-82.us-east-2.compute.internal
  Normal   BackOff    <invalid> (x3 over 18s)  kubelet, ip-10-0-134-82.us-east-2.compute.internal  Back-off pulling image "docker.io/busyboxtest"
  Warning  Failed     <invalid> (x3 over 18s)  kubelet, ip-10-0-134-82.us-east-2.compute.internal  Error: ImagePullBackOff
  Normal   Pulling    <invalid> (x3 over 18s)  kubelet, ip-10-0-134-82.us-east-2.compute.internal  Pulling image "docker.io/busyboxtest"
  Warning  Failed     <invalid> (x3 over 18s)  kubelet, ip-10-0-134-82.us-east-2.compute.internal  Failed to pull image "docker.io/busyboxtest": rpc error: code = Unknown desc = Error reading manifest latest in docker.io/library/busyboxtest: errors:
denied: requested access to the resource is denied
unauthorized: authentication required
  Warning  Failed  <invalid> (x3 over 18s)  kubelet, ip-10-0-134-82.us-east-2.compute.internal  Error: ErrImagePull


The event with Type `Normal` are shown as Normal on console
The event with Type `Warning` are shown as Warning on console, warning events are shown in yellow color 


Verified on 4.4.0-0.nightly-2019-12-15-184910

Comment 4 errata-xmlrpc 2020-05-04 11:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.