Bug 1749499 - Can't continue after import errors at /usr/bin/shutter line 57.
Summary: Can't continue after import errors at /usr/bin/shutter line 57.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shutter
Version: 31
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Liang Suilong
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1755554 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-05 18:28 UTC by yucef sourani
Modified: 2019-12-11 08:07 UTC (History)
11 users (show)

Fixed In Version: shutter-0.94.3-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-11 02:06:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description yucef sourani 2019-09-05 18:28:04 UTC
Version-Release number of selected component (if applicable):
shutter-0.93.1-14.fc31.noarch
perl-interpreter-5.30.0-445.fc31.x86_64


ERROR:
Can't continue after import errors at /usr/bin/shutter line 57.
BEGIN failed--compilation aborted at /usr/bin/shutter line 57.

see this link .
https://bugs.launchpad.net/shutter/+bug/1831155

Comment 1 Martin Ueding 2019-11-02 20:46:15 UTC
*** Bug 1755554 has been marked as a duplicate of this bug. ***

Comment 2 Mike Heffner 2019-11-04 03:20:29 UTC
Any bump on this? Making the similar changes from the diff in the launchpad ticket allows shutter to start.

Comment 3 Mike Heffner 2019-11-11 15:08:00 UTC
(In reply to Mike Heffner from comment #2)
> Any bump on this? Making the similar changes from the diff in the launchpad
> ticket allows shutter to start.

I've created a Copr with the latest 0.94.x version that fixes this: https://copr.fedorainfracloud.org/coprs/mheffner/shutter/

Comment 4 Mike Heffner 2019-11-11 15:08:16 UTC
(In reply to Mike Heffner from comment #2)
> Any bump on this? Making the similar changes from the diff in the launchpad
> ticket allows shutter to start.

I've created a Copr with the latest 0.94.x version that fixes this: https://copr.fedorainfracloud.org/coprs/mheffner/shutter/

Comment 5 xzj8b3 2019-11-11 16:38:39 UTC
tenks now running thanks a lot

Comment 6 Franky 2019-11-18 13:46:47 UTC
By changing the value

use File::Glob qw/ glob /;

to 

use File::Glob qw/ bsd_glob /;

in both files

/bin/shutter

and

/usr/share/perl5/vendor_perl/Shutter/Draw/DrawingTool.pm

I was able to start shutter again.

Seems this was an old bug https://bugs.launchpad.net/shutter/+bug/1831155, that happened to pop up again.

Comment 7 eisraeli 2019-11-19 09:44:59 UTC
Franky helped me getting shutter running, but the screenshot functionality seems to be completely broken.

Comment 8 Martin Ueding 2019-11-19 10:43:32 UTC
Applying [this patch](https://bazaar.launchpad.net/~shutter/shutter/devel/revision/1304) fixed it for me, and also screenshots work just as usual.

Comment 9 strasharo2000 2019-11-24 14:20:15 UTC
Hit the same issue on Fedora 31:

"glob" is not exported by the File::Glob module
Can't continue after import errors at /usr/bin/shutter line 57.
BEGIN failed--compilation aborted at /usr/bin/shutter line 57.

Comment 10 David Streichl 2019-11-26 12:27:12 UTC
Thank you. Comment #3 works for me.

Comment 11 eisraeli 2019-11-26 12:36:08 UTC
I see some people report working functionality after applying this patch.

Yet, for some reason this is how screenshots look for me:

https://imgur.com/a/36hKbsC

Comment 12 yucef sourani 2019-11-28 17:09:54 UTC
(In reply to eisraeli from comment #11)
> I see some people report working functionality after applying this patch.
> 
> Yet, for some reason this is how screenshots look for me:
> 
> https://imgur.com/a/36hKbsC

on wayland ?

Comment 13 Fedora Update System 2019-12-09 14:28:06 UTC
FEDORA-2019-973addd47d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-973addd47d

Comment 14 Fedora Update System 2019-12-10 18:47:19 UTC
shutter-0.94.3-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-973addd47d

Comment 15 Fedora Update System 2019-12-11 02:06:16 UTC
shutter-0.94.3-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 eisraeli 2019-12-11 08:07:29 UTC
Just tried to install it again on Fedora 31 and still getting the same error:

"glob" is not exported by the File::Glob module
Can't continue after import errors at /usr/bin/shutter line 57.
BEGIN failed--compilation aborted at /usr/bin/shutter line 57.


Note You need to log in before you can comment on or make changes to this bug.