Bug 1749575 - upower.service fails to start on current Rawhide installs due to SELinux: denied { create } for pid=1111 comm="(upowerd)" name="upower" scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:devicekit_var_lib_t:s0 tclass=dir
Summary: upower.service fails to start on current Rawhide installs due to SELinux: den...
Keywords:
Status: CLOSED DUPLICATE of bug 1748997
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks: F32FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-05 22:14 UTC by Adam Williamson
Modified: 2019-09-06 08:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 08:26:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2019-09-05 22:14:24 UTC
In current Rawhide, upower.service fails to start after a fresh install, due to an SELinux denial:

Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1]: Starting Daemon for power management...
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1111]: upower.service: Failed to set up special execution directory in /var/lib: Permission denied
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1111]: upower.service: Failed at step STATE_DIRECTORY spawning /usr/libexec/upowerd: Permission denied
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com audit[1111]: AVC avc:  denied  { create } for  pid=1111 comm="(upowerd)" name="upower" scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:devicekit_var_lib_t:s0 tclass=dir permissive=0
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1]: upower.service: Main process exited, code=exited, status=238/STATE_DIRECTORY
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1]: upower.service: Failed with result 'exit-code'.
Sep 05 02:46:58 ibm-p8-kvm-03-guest-02.virt.pnr.lab.eng.rdu2.redhat.com systemd[1]: Failed to start Daemon for power management.

Proposing as an F32 Final blocker, as this violates "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present" for the Workstation and KDE package sets.

Comment 1 Lukas Vrabec 2019-09-06 08:26:51 UTC

*** This bug has been marked as a duplicate of bug 1748997 ***


Note You need to log in before you can comment on or make changes to this bug.