Bug 174958 - Kernel Mischief: various problems, intermittantly
Kernel Mischief: various problems, intermittantly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 18:02 EST by Brian Fahrlander
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 18:08:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Fahrlander 2005-12-04 18:02:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Unhindered by an abundance of money, I'm still running FC4 on the exact same hardware I was running RH8/9.  Serious changes are starting to really impact my day, and they appear to be at the kernel level...the level that's historically been solid.

1. Keyboard
From time to time, and without any visible reason, the keyboard "dies".  I'm typing one minute and not, the next.  If I unplug the keyboard and plug it back in, we're back on the road.  It's a PS/2, in the simple, PS/2 port.  This is almost an everyday occurance.

I also have a problem with the left control key; it doesn't always respond, and I wind up typing in lower case until I notice it, and re-type it.  It's also doing this on a spare keyboard, it's not the mechanism.

2. Mouse
I have a very old, trusty Logitech Optical Mouse that's been solid for at least four years.  But now it, too, stops working, requiring the USB plug to be unplugged, and plugged back in.  This happens at least once a week, sometimes twice.

It also responds multiple times to button clicks, but I'm sure that's just due to the age of the device.

3. Recent kernel versions have a worsening problem, from my point of view:
a. 3-second stuttering in 3D applications.  In UnrealTournament, Quake 3, and Enemy Territory all have an annoying 3-second delay on no particular schedule. Since these are real-time games, you can see what a broomstick-in-the-spokes it is.
b. Streaming media is problematic.  Both XMMS and RB until recently would kick into fast-forward. I'd have to stop it, and restart it to get it to go.  It was part of the I/O Scheduler; it happens a lot less often using Anticipatory. In the last week, the problem has begun to STOP these programs, and in the case of RB, it's killing the program.  (!)
c. The machine hangs; no schedule, no clues.

The machine here is an Athlon 1200, using the VIA chipset...not known for it's high throughput, but can that be the only problem?  Maybe it's a problem with my hardware?

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1644_FC4

How reproducible:
Sometimes

Steps to Reproduce:
Problem(s) occur in a random order.

Actual Results:  Most times, it works. Sometimes it hangs, and I'm rebooting daily, now.

Expected Results:  Everything normal.

Additional info:

I'm happy to set up the system to be investigated from the outside, and I'm happy to help in any way I'm able.
Comment 1 Pete Zaitcev 2005-12-04 19:23:11 EST
How's the memtest86 doing on that box? I saw systems going bad in the
middle of an installation before.

And I shudder to think what if ACPI does something bad. We'll never find it.
But it may be worth it to try to disable ACPI with various kernel options...
RHL9 didn't have it, IIRC.
Comment 2 Brian Fahrlander 2005-12-05 11:24:13 EST
Well, memtest86 ran fine for a few hours...though this isn't a new install; it's
been installed for a couple of momths.

This morning in the first two hours back online, it locked 4 times at random,
locked the entire machine twice, and killed RB 4-5 times as well...

And I've turned off ACPI to limit the number of possible sources....no joy....
Comment 3 Brian Fahrlander 2005-12-05 21:34:52 EST
More data: when "sitting still" running the TV capture card and watching
Gkrellm, I noticed something: the TV delays "pulse" in time with the network
access.  I'm using NFS here, a shared /home directory and /shares (communally
shared media, etc) with nothing special at the workstation.

Are there any network-card/kernel bugs I'm not able to find here?
Comment 4 Brian Fahrlander 2005-12-07 15:22:02 EST
Well, there's egg on MY face.  My trusty machine who's been with me for so long
has finally died.

I tested the same kinds of things on a similar box (one on to which I finally
fell back) and none of the serious problems were there.  The pulsing, the 3D
delays, all of this happened on a machine that's been gradually getting worse
for some time.  Memtest showed nothing, the whole time.

Is there any computer forensics project going on?  My experience until now has
been that computer problems tend to be "digital", being a problem or not...even
with they're intermittant.  It's really odd to see one creep up like rust.

Thanks guys- sorry to have wasted your time.
Comment 5 Pete Zaitcev 2005-12-07 18:08:51 EST
My sympathies...

Note You need to log in before you can comment on or make changes to this bug.