Bug 1749586 - Entries on logs screen seem to be missing some styling in Cockpit 202
Summary: Entries on logs screen seem to be missing some styling in Cockpit 202
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: 31
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matej Marušák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-05 23:19 UTC by Adam Williamson
Modified: 2019-09-14 16:34 UTC (History)
4 users (show)

Fixed In Version: cockpit-202.1-1.fc30 cockpit-202.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 03:13:01 UTC
Type: Bug


Attachments (Terms of Use)
how it looked before (87.95 KB, image/png)
2019-09-05 23:22 UTC, Adam Williamson
no flags Details
how it looks now (76.99 KB, image/png)
2019-09-05 23:22 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2019-09-05 23:19:24 UTC
As I mentioned on the F31 and F30 updates:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-cb9233ff6c
https://bodhi.fedoraproject.org/updates/FEDORA-2019-1446526b5e

there seems to be a problem with the Logs screen in cockpit 202. The various elements for each log entry appear one per line, without any/much styling applied. From 198 to 201, all the elements for each log entry appeared on a single line, with various bits of styling applied to them. I'll attach screenshots.

I'm filing a bug now because I see this is affecting the Rawhide openQA tests, so having a bug report is useful.

Comment 1 Adam Williamson 2019-09-05 23:22:00 UTC
Created attachment 1612112 [details]
how it looked before

Comment 2 Adam Williamson 2019-09-05 23:22:34 UTC
Created attachment 1612113 [details]
how it looks now

Comment 4 Martin Pitt 2019-09-06 05:21:47 UTC
This isn't just unlucky styling for small screen sizes, it happens on big screens as well. There were no direct styling changes to the Logs page between 201 and 202, so this must have been some inadvertent side effect of some generic CSS changes, or possibly a new PF or other npm version. Matej, can you please have a look?

Comment 5 Adam Williamson 2019-09-06 06:09:46 UTC
It may affect other pages too, note - Logs is the first the openQA test checks. It usually checks Services afterwards, bur because Logs fails, that's skipped.

Comment 6 Matej Marušák 2019-09-06 09:14:25 UTC
Thanks for the report. It is easy to reproduce - just installing cockpit 202 from repos on my normal F30.
Also most of these issues I see on master (but I had to clean everything and `make` everything from scratch)
I noticed a few broken things:
1. Logs as reported
2. Inlined logs (like in storage or in services)
3. Services list is a bit different
4. Names in storage (like name of volume or drive) is way to big and breaks UI (I cannot reproduce this with master only happens with package)
5. Items in Accounts lost contrast

Not just design but functional:
1. On System page graphs show only units but no values (like only showing `MiB/s Disk I/O` and not `40 MiB/s Disk I/O`

Comment 7 Matej Marušák 2019-09-06 09:37:12 UTC
Ok, so with bisecting I found the culprit:
https://github.com/cockpit-project/cockpit/commit/dabebcab33d7a38488338035d7db537984e5ef9a

Reverting this commit fixes:
> 1. Logs as reported
> 2. Inlined logs (like in storage or in services)
> 3. Services list is a bit different
> 5. Items in Accounts lost contrast

Comment 8 Matej Marušák 2019-09-06 12:56:00 UTC
Upstream PR: https://github.com/cockpit-project/cockpit/pull/12729

> 4. Names in storage (like name of volume or drive) is way to big and breaks UI (I cannot reproduce this with master only happens with package)
I cannot reproduce this locally. I'll try to compare css files from package and locally built

> 1. On System page graphs show only units but no values (like only showing `MiB/s Disk I/O` and not `40 MiB/s Disk I/O`
Ah, I just realized I was reading this wrong :D This is correct, but since it was a bit mis-styled (fixed in the same PR) it seemed like it should have some additional text.

Comment 9 Adam Williamson 2019-09-06 14:55:26 UTC
thanks folks, score another point for screenshot-based testing I guess :P

Comment 10 Martin Pitt 2019-09-09 18:37:09 UTC
This was fixed in today's extracurricular release 202.1. It's a rather huge regression (by our standards, anyway) and quite embarrassing.

Comment 11 Fedora Update System 2019-09-09 18:38:01 UTC
FEDORA-2019-64cf30d787 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-64cf30d787

Comment 12 Fedora Update System 2019-09-09 18:38:15 UTC
FEDORA-2019-3a762c57a9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3a762c57a9

Comment 13 Fedora Update System 2019-09-09 23:16:08 UTC
cockpit-202.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3a762c57a9

Comment 14 Fedora Update System 2019-09-11 03:13:01 UTC
cockpit-202.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-09-14 16:34:19 UTC
cockpit-202.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.