Bug 17497 - unable to rebuild src.rpm's
Summary: unable to rebuild src.rpm's
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-14 11:50 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-09-14 11:51:16 UTC


Attachments (Terms of Use)

Description Need Real Name 2000-09-14 11:50:32 UTC
I'm not sure if this bug has something to do with binutils. If not, sorry
for that.

Since one of the security updates of the last two weeks or so (glibc?) I am
unable to rebuild src.rpm's, which were working perfectly until a few weeks
ago. I found that "strip" had something to do with this, which doesn't mean
that the cause is "strip" of course. I also tried to rebuild binutils but
with the same result. I posted a tee output of ssh.src.rpm on my website.

This is what happens when I rebuild ssh-1.2.27-7i.src.rpm:

http://www.casema.net/~pe1bbf/ssh.txt (full log)

This is what happens when I rebuild binutils-2.9.5.0.22-6.src.rpm

+ strip /var/tmp/binutils-root/usr/bin/ar /var/tmp/binutils-root/usr/bin/as
/var/tmp/binutils-root/usr/bin/ld /var/tmp/binutils-root/usr/bin/nm
/var/tmp/binutils-root/usr/bin/ranlib /var/tmp/binutils-root/usr/bin/strip
strip: /var/tmp/binutils-root/usr/bin/strip: simple_copy: Text file busy
+ gzip -q9f /var/tmp/binutils-root/usr/info/*.info*
/var/tmp/binutils-root/usr/info/*.info*: No such file or directory
Bad exit status from /var/tmp/rpm-tmp.77863 (%install)

Comment 1 Need Real Name 2000-09-16 12:19:41 UTC
I found out that rpm-3.0.5 is guilty.


Note You need to log in before you can comment on or make changes to this bug.