Bug 1749765 - oauth-proxy - backport various fixes from 4.1 to 3.11
Summary: oauth-proxy - backport various fixes from 4.1 to 3.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.11.z
Assignee: Standa Laznicka
QA Contact: Anping Li
URL:
Whiteboard:
Depends On: 1762750
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-06 11:58 UTC by Standa Laznicka
Modified: 2020-02-19 19:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-19 19:53:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oauth-proxy pull 135 0 'None' closed Bug 1749765: 3.11 backports 2020-02-26 01:39:26 UTC
Red Hat Product Errata RHBA-2020:0402 0 None None None 2020-02-19 19:53:57 UTC

Description Standa Laznicka 2019-09-06 11:58:34 UTC
Description of problem:
There was a couple of fixes to oauth-proxy in 4.1 that are key to stability to the component. Since we officially have the 3.11 branch in that repository now and it is used by the ART team to build releases from, leverage the process and create a backport for all things 4.1 to the new 3.11 branch.


Version-Release number of selected component (if applicable):
3.11

Comment 4 Anping Li 2020-01-19 11:04:01 UTC
Move to modified status. Waiting oauth-proxy images 3.11.165

Comment 6 Anping Li 2020-02-04 07:50:08 UTC
Oauth-proxy:v3.11.169 Regression pass

Comment 8 errata-xmlrpc 2020-02-19 19:53:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0402


Note You need to log in before you can comment on or make changes to this bug.