Bug 1750052 - GlusterFS repository broken
Summary: GlusterFS repository broken
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-07 20:21 UTC by hostmaster
Modified: 2019-09-23 13:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-23 13:23:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hostmaster 2019-09-07 20:21:28 UTC
Description of problem:
I tried installing GlusterFS from the official repo (https://download.gluster.org/pub/gluster/glusterfs/LATEST/) but keep getting "GnuTLS recv error (-9): A TLS packet with unexpected length was received.". Downloading debs with a browser (Chrome) from https://download.gluster.org/pub/gluster/glusterfs/LATEST/Debian/9/amd64/apt/pool/main/g/glusterfs/ fails, too.


Version-Release number of selected component (if applicable):
all


How reproducible:
Install GlusterFS on Debian Stretch from the official repo or download https://download.gluster.org/pub/gluster/glusterfs/LATEST/Debian/9/amd64/apt/pool/main/g/glusterfs/glusterfs-common_6.5-1_amd64.deb with Chrome


Steps to Reproduce:
1. Download https://download.gluster.org/pub/gluster/glusterfs/LATEST/Debian/9/amd64/apt/pool/main/g/glusterfs/glusterfs-common_6.5-1_amd64.deb with Chrome

Actual results:
File download cancels with an error. On apt install glusterfs-client the following error occurs: GnuTLS recv error (-9): A TLS packet with unexpected length was received.


Expected results:
File download is successful. Installation from packages in Debian is succesful.

Comment 2 Nithya Balachandran 2019-09-09 03:10:02 UTC
This is referring to a community release - changing BZ accordingly.

Comment 3 M. Scherer 2019-09-23 12:50:35 UTC
Ok, so can you give a bit more information ?

1) what do you mean by "Install GlusterFS on Debian Stretch from the official repo". official being the Debian one, or the  Glusterfs one ?

2) does it work if you download using curl or wget ? I have no problem from my own server with those (and not going to install chrome on it if I can avoid)

3) does it work with firefox, or another browser ?

4) what version of chrome and where does it come from ?

Comment 4 hostmaster 2019-09-23 12:57:37 UTC
1. The officially reported repository of glusterfs https://download.gluster.org/pub/gluster/glusterfs/LATEST/
2. As stated in the bug report download wasn't working, too
3. Not checked, only checked installation on Debian Stretch and manually downloading packages via Chrome
4. Official Chromium Version 76.0.3809.100 Ubuntu/Linux Mint 19.1

A few hours after reporting this issue, I was able to install successfully. Seemed to be a temporary issue with the repo which might be solved already.

Comment 5 M. Scherer 2019-09-23 13:00:00 UTC
so, you can't reproduce for now ? 

Was it on a regular home internet, or could it have been a middlebox doing some kind of DPI or inspection on the traffic if that was in a DC ? 

When did it occurs, do you have the outgoing IP and time so I can check our log if something suspicious happened ?

Comment 6 hostmaster 2019-09-23 13:02:24 UTC
Installation (Debian Stretch) was tried on a VM in a datacenter with dedicated network, Chrome download was tried with my home computer in my home network.
I did not record the IPs, but it happened a few minutes before creating this issue.

Comment 7 M. Scherer 2019-09-23 13:16:11 UTC
oh wow, I didn't see this issue was so old, sorry to not have answered earlier, it seems to have been directed to us correctly. I do not see much on our side on the 9 of september, but it could have been some issue on our firewalls or something (my team do not control the firewall, and we also have one more layer between us and the ISP :/ ). 

So if that's not reproductible, I would classify as "network temporary issue", but keep in mind if this happen again and close it.

Comment 8 hostmaster 2019-09-23 13:17:50 UTC
Fine for me, I will come back to you, if it happens for me again.

Regards

Comment 9 Kaleb KEITHLEY 2019-09-23 13:23:22 UTC
Packages on download.gluster.org are not "official" in any sense of the word. They are built by the community as a convenience for the community.

By most people's definition, "official" packages are those that come from Debian itself or Debian mirrors.

Nothing has changed in the repos on download.gluster.org; not since 2019-08-12, when glusterfs-6.5 and glusterfs-5.9 packages were made available.

AFAIK, and IIRC, there was an issue with Debian certs several months ago that caused issues with installing packages with apt.

Installing with apt works (for me) as does downloading with firefox.

Also request that instead of opening a BZ for this sort of thing that you consider one of several alternatives: a) send email to gluster-users@gluster.org or gluster-devel@gluster.org, b) post to #gluster-dev @freenode IRC, or c) post to the #gluster channel on Slack. Those will most likely get a response faster than opening a BZ.

Closing this is WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.