Bug 1750194 - No sound on broadwell-rt286 hardware, firmware fails to load
Summary: No sound on broadwell-rt286 hardware, firmware fails to load
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1760392 (view as bug list)
Depends On:
Blocks: 1759432 1772498
TreeView+ depends on / blocked
 
Reported: 2019-09-09 02:06 UTC by TL
Modified: 2019-11-19 09:01 UTC (History)
22 users (show)

Fixed In Version: kernel-5.3.9-300.fc31 kernel-5.3.11-100.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-12 02:21:12 UTC
Type: Bug


Attachments (Terms of Use)
kernel logs (70.76 KB, text/plain)
2019-09-09 02:06 UTC, TL
no flags Details

Description TL 2019-09-09 02:06:18 UTC
Created attachment 1612973 [details]
kernel logs

1. Please describe the problem: 
There is no sound through the Broadwell card, but sound does work through bluetooth.  System log errors include:
broadwell-audio broadwell-audio: ASoC: failed to init link System PCM: -517
haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 failed 

2. What is the Version-Release number of the kernel: 
5.2.11-200


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :
It worked previously on Fedora 30, but can't remember last kernel on which it did.

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:
Attempt to play any sound video in any browser, or using aplay on any sound file.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Haven't tried, but did try on earlier kernels 5.2.9-200 and 5.2.8-200, same problem.

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 TL 2019-09-23 01:37:46 UTC
Confirmed that sound works fine on the last 5.1 kernel (5.1.20-300) (i.e. no problem), so appears it problem was introduced in 5.2.x kernels.

Comment 2 TL 2019-09-24 02:53:24 UTC
Confirmed that bug is introduced in at least kernel-5.2.2-200 onward to current kernels.  (Couldn't test kernel-5.2.1-200 because it doesn't startup at all).

Comment 3 David Ward 2019-10-25 03:08:41 UTC
Upstream kernel bug: https://bugzilla.kernel.org/show_bug.cgi?id=204237

Comment 4 David Ward 2019-10-28 17:41:39 UTC
Fedora kernel maintainers:

According to Intel [1], the problem is with Fedora's kernel configuration. It is apparently invalid to select both CONFIG_SND_SOC_INTEL_SST_TOPLEVEL and CONFIG_SND_SOC_SOF_INTEL_TOPLEVEL (even though this is not enforced by Kconfig). This conflict is supposed to be addressed in a future kernel version [2].

Although CONFIG_SND_SOC_SOF_INTEL_TOPLEVEL defaults to N, it has been set to Y in Fedora. (This setting was introduced in kernel 5.2-rc1.) Aside from the conflict above, this setting requires firmware files [3] that are not currently built or packaged in Fedora.

Can you please set CONFIG_SND_SOC_SOF_INTEL_TOPLEVEL to N in the Fedora kernel package for now? This will restore sound on the affected platforms. Thank you.


[1] https://bugzilla.kernel.org/show_bug.cgi?id=204237#c15
[2] https://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git/commit/?id=82d9d54a6c0ee8b12211fa4e59fd940a2da4e063
[3] https://github.com/thesofproject/sof

Comment 5 Laura Abbott 2019-10-29 13:14:12 UTC
*** Bug 1760392 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-11-07 15:29:02 UTC
FEDORA-2019-6442f3f5e8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6442f3f5e8

Comment 7 Fedora Update System 2019-11-07 15:30:12 UTC
FEDORA-2019-0eef22c0e3 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0eef22c0e3

Comment 8 Fedora Update System 2019-11-07 15:31:05 UTC
FEDORA-2019-efd1043020 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-efd1043020

Comment 9 Jaroslav Kysela 2019-11-08 10:50:49 UTC
The fix is not ideal. We need those upstream commits to let all Intel drivers working:
 
  82d9d54a6c0ee8b12211fa4e59fd940a2da4e063
    ALSA: hda: add Intel DSP configuration / probe code
  cc8f81c7e625168a60843b2b39e3a327cf5170fe
    ALSA: hda: fix intel DSP config
  d745cc1ab65945b2d17ec9c5652f38299c054649
    ASoC: intel - fix the card names

The patches fix the correct driver auto-selection and the driver names for the Use Case Manager.

https://src.fedoraproject.org/fork/perex/rpms/kernel/commits/perex/intel-sof

Comment 10 David Ward 2019-11-08 12:56:39 UTC
(In reply to Jaroslav Kysela from comment #9)
> The fix is not ideal. We need those upstream commits to let all Intel
> drivers working:

Which Intel platforms do not have working sound using the Intel ASoC SST drivers?

Using the SOF driver requires separate a platform-specific firmware blob to be installed. Is that packaged in Fedora yet? I couldn't find it.

Comment 11 Laura Abbott 2019-11-08 14:16:59 UTC
We also need the patches on 5.3.x as well. I went with turning off the options because the patches didn't seem to apply cleanly to f30/f31 (it's also possible I missed a dependency)

Comment 12 David Ward 2019-11-08 15:35:52 UTC
Those patches actually wouldn't fix this bug either: https://bugzilla.kernel.org/show_bug.cgi?id=204237#c20

Here's a further patchset that has been merged into linux-next, but that I was similarly unable to apply onto 5.3.x:
https://github.com/thesofproject/linux/pull/1382

Description:
"We have a number of issues with distros selecting options that make no sense.
Let's try and be more explicit about what they should use."

Comment 13 Jaroslav Kysela 2019-11-09 10:47:15 UTC
(In reply to David Ward from comment #10)
> (In reply to Jaroslav Kysela from comment #9)
> > The fix is not ideal. We need those upstream commits to let all Intel
> > drivers working:
> 
> Which Intel platforms do not have working sound using the Intel ASoC SST
> drivers?

All CNL (Cannonlake) platforms with the DMIC (digital microphone) connected to DSP like Lenovo Carbon X1 7th gen. The internal microphone does not work for them.

> Using the SOF driver requires separate a platform-specific firmware blob to
> be installed. Is that packaged in Fedora yet? I couldn't find it.

Yes, we don't have this fw in Fedora. But it's another story. We also need to update UCM (I'm working on this in upstream).

My SOF FW tar ball: http://people.redhat.com/~jkysela/sof/sof-firmware-v1-3-1.tgz

(In reply to David Ward from comment #12)
> Those patches actually wouldn't fix this bug either:
> https://bugzilla.kernel.org/show_bug.cgi?id=204237#c20
> 
> Here's a further patchset that has been merged into linux-next, but that I
> was similarly unable to apply onto 5.3.x:
> https://github.com/thesofproject/linux/pull/1382
> 
> Description:
> "We have a number of issues with distros selecting options that make no
> sense.
> Let's try and be more explicit about what they should use."

Yes, it seems that Intel does not fully understand our requirement to enable all drivers at the kernel build time and choose the right one automatically at run-time.

I will work further on this.

Comment 14 Fedora Update System 2019-11-09 23:20:34 UTC
kernel-5.3.9-300.fc31, kernel-tools-5.3.9-300.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6442f3f5e8

Comment 15 Fedora Update System 2019-11-10 00:39:19 UTC
kernel-5.3.9-200.fc30, kernel-tools-5.3.9-200.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0eef22c0e3

Comment 16 TL 2019-11-10 03:14:10 UTC
Following the instructions under 'How to Install' on the testing page (https://bodhi.fedoraproject.org/updates/FEDORA-2019-6442f3f5e8), I get "Nothing to do", and nothing installs:

# dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-6442f3f5e8
Last metadata expiration check: 0:03:02 ago on Sat 09 Nov 2019 07:58:17 PM EST.
No security updates needed, but 119 updates available
Dependencies resolved.
Nothing to do.
Complete!

I am, fwiw, attempting this testing upgrade from an F31 instance, albeit running an earlier F30-built kernel:

# cat /etc/fedora-release
Fedora release 31 (Thirty One)

# uname -a
Linux localhost.localdomain 5.1.20-300.fc30.x86_64 #1 SMP Fri Jul 26 15:03:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

# rpm -qa | grep kernel-core
kernel-core-5.3.8-200.fc30.x86_64
kernel-core-5.1.20-300.fc30.x86_64
kernel-core-5.3.8-300.fc31.x86_64

Could someone please advise? Thanks.

Comment 17 Fedora Update System 2019-11-10 04:35:34 UTC
kernel-5.3.9-100.fc29, kernel-tools-5.3.9-100.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-efd1043020

Comment 18 Peter Robinson 2019-11-10 13:24:12 UTC
> Could someone please advise? Thanks.

Probably didn't make it to the mirrors yet. I'd try it again now.

Comment 19 David Ward 2019-11-10 13:36:33 UTC
(In reply to Peter Robinson from comment #18)
> > Could someone please advise? Thanks.
> 
> Probably didn't make it to the mirrors yet. I'd try it again now.

Actually, it's still not had enough time to propagate to all the tier 2 mirrors.
https://fedoraproject.org/wiki/Infrastructure/Mirroring/Tiering

Comment 20 TL 2019-11-10 18:45:34 UTC
Looks like it got pushed out, just tried it for F31 and it appears to fix the problem (yay!).  Will report on the testing page.  Many thanks to David Ward and all the other folks who have commented and helped.  All best, TL

Comment 21 Fedora Update System 2019-11-12 02:21:12 UTC
kernel-5.3.9-300.fc31, kernel-tools-5.3.9-300.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-11-13 06:47:30 UTC
kernel-5.3.11-100.fc29, kernel-headers-5.3.11-100.fc29, kernel-tools-5.3.11-100.fc29, microcode_ctl-2.1-33.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2019-11-13 09:56:57 UTC
kernel-5.3.9-200.fc30, kernel-tools-5.3.9-200.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 morgan read 2019-11-18 20:01:12 UTC
Yay, sound again
$ uname -r
5.3.11-200.fc30.x86_64
(not before)

Comment 25 Jaroslav Kysela 2019-11-19 09:01:12 UTC
We need to enable the SOF driver in Fedora for 5.4 kernels. Please, could you test the kernel from bug#1772498, if the audio is functional on your hardware with it? Thank you.


Note You need to log in before you can comment on or make changes to this bug.