Bug 175020 - screen is blank during installation (no video signal)
screen is blank during installation (no video signal)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 14:11 EST by Peter Quiring
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 03:49:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Quiring 2005-12-05 14:11:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
During installation right after anaconda (x11) does hardware detection the screen goes blank (no video signal), yet the disc continues to be accessed (looks like the installer is still running).  Even if I wait a while and press ENTER the disc is accessed again briefly.  My hardware is as follows:
  AMD 64bit
  ATI Radeon X800 XL (AGP)
The auto-detect says it's (PCIe) which is incorrect.

I tried to use FC4 and it works but uses only the 'VESA generic' driver.


Version-Release number of selected component (if applicable):
FC5 test1

How reproducible:
Always

Steps to Reproduce:
1.Install FC5test1
2.Autodetect shows hardware
3.screen goes blank (no video signal)
  

Actual Results:  No video signal.

Expected Results:  See installer on my monitor.

Additional info:

I guess I could try and navigate thru the installer blindly and see if it works, but I will have to try this another time.
Comment 1 Ignacio Vazquez-Abrams 2005-12-05 14:25:51 EST
What monitor? Does the monitor have a method of showing what frequencies are
being used?
Comment 2 Peter Quiring 2005-12-06 00:24:46 EST
Monitor is a Relisys RE786.  

When the installer crashes the screen goes blank and the power LED flashes
yellow.  There is nothing I can do while in this mode.
If the monitor is unplugged from video card the screen shows a test pattern.
If the monitor is in sleep mode, the LED is a constant yellow.

I've tried to use another video card (nVidia GeForce FX 5200 - AGP) and then it
works.  Looks like a problem with the ATI driver.
Comment 3 Peter Quiring 2006-01-11 22:04:17 EST
I found another similar bug on freedesktop.org and they fixed the issue by
editing the xorg.conf file.  How would I do that during installation though?
Comment 4 Peter Quiring 2006-01-11 23:29:25 EST
FYI - If I use the i386 rawhide then the video works fine.  But using the same
dated x86_64 rawhide and it still doesn't work.  How the code differ from i386
to x86_64?
Comment 5 Mike A. Harris 2006-01-31 15:21:11 EST
Attach the output of "lspci -vvn", and attach your X server log and config
file as individual uncompressed file attachments.

(In reply to comment #4)
> FYI - If I use the i386 rawhide then the video works fine.  But using the same
> dated x86_64 rawhide and it still doesn't work.  How the code differ from i386
> to x86_64?

The same source code is used on all architectures, however there are a
great many reasons why it may work on i386 and not work on x86_64 mode, even
on the same machine.  There is a fair bit of conditional code throughout
the X server, and all drivers, and there are various CPU specific and/or
family specific features that only work on specific arch.  For example,
vm86 mode is only available on x86, and is not supported in long mode.
So in x86_64 mode, the x86 emulator is used to execute the video BIOS
code.

That is only one example of many reasons why you might experience a failure
in x86_64, which is not reproduceable in i386 mode on the same system.
Rather than worrying about that though, lets just focus on the problem, and
try to diagnose what is happening and fix it.

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129
Fedora/1.5-1 Firefox/1.5
> 
> Description of problem:
> During installation right after anaconda (x11) does hardware detection the
screen goes blank (no video signal), yet the disc continues to be accessed
(looks like the installer is still running).  Even if I wait a while and press
ENTER the disc is accessed again briefly.  My hardware is as follows:
>   AMD 64bit
>   ATI Radeon X800 XL (AGP)
> The auto-detect says it's (PCIe) which is incorrect.

Autodetection simply takes the PCI ID of the hardware, and looks it up in
a database.  If a match is found, the cosmetic name of the hardware is
taken from the database and displayed.  Many video cards come in different
bus configurations, but use the same PCI ID.  For example, the Radeon X800 XL
card probably has the same PCI ID for both the AGP card and the PCI-E card,
making them indistinguishable by PCI ID.

The hardware detection phase of OS installation and/or video configuration
however, does not really care wether a card is PCI/AGP/PCI-E, as all it
really needs to know, is what video driver it should configure the X server
to use for that card.  So, it grabs the PCI ID from the card, looks it up
in the pci database, which determines what driver should be used, and the
xorg.conf gets configured to use that driver.  The name displayed on the
screen, which may or may not say "AGP" or "PCI-E" is only a cosmetic name
for display on screen, and has no effect on the driver chosen or operation
of the driver.   When the X server is actually started, and loads the
driver that was chosen, the driver initializes, and it determines wether
the card is a PCI/AGP/PCI-E card, etc.

Assuming the driver detection is correct, everything should be ok.


> I tried to use FC4 and it works but uses only the 'VESA generic' driver.

Right, the X800 series hardware wasn't supported in Xorg 6.8.2.

> I guess I could try and navigate thru the installer blindly and see if it
works, but I will have to try this another time.

In order to diagnose the problem, try a text mode install, update to the
latest Fedora devel packages, and run "system-config-display --reconfig",
then test the X server.  Update the report to indicate the current status.
If the problem is still present, please attach your X server log and config
file as individual uncompressed file attachments using the link below.

Also, try the "vesa" driver as another potential temporary workaround.

Once you've had a chance to test this and update the report, we'll try to
narrow things down further if the problem is still present.

Thanks in advance.
Comment 6 Mike A. Harris 2006-02-07 05:22:43 EST
ping
Comment 7 Peter Quiring 2006-02-07 12:47:47 EST
Sorry, I'm using the i386 verson for now and it works great.  This is good
enough for me.  You can close the ticket.  Thanks.
Comment 8 Mike A. Harris 2006-02-08 03:49:35 EST
Ok..

Closing as per request above.

Setting resolution to "CANTFIX"  (without more information)
Comment 9 Peter Quiring 2006-04-20 19:46:37 EDT
FYI - It works okay in FC5 final, you could reopen and close as "fixed" if you like.
Comment 10 Mike A. Harris 2006-04-20 20:40:19 EDT
Thanks, changing status to "CURRENTRELEASE -> FC5"

Note You need to log in before you can comment on or make changes to this bug.