Bug 1750259 - [BACKPORT] backport of upstream patch to Replace coremask with cpu_list in vrouter dpdk schema
Summary: [BACKPORT] backport of upstream patch to Replace coremask with cpu_list in vr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z9
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1750612
TreeView+ depends on / blocked
 
Reported: 2019-09-09 07:43 UTC by PURANDHAR SAIRAM MANNIDI
Modified: 2019-11-07 14:02 UTC (History)
7 users (show)

Fixed In Version: os-net-config-8.4.4-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1750612 (view as bug list)
Environment:
Last Closed: 2019-11-07 14:02:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 680921 None MERGED Replace coremask with cpu_list in vrouter schema 2020-03-30 18:25:02 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:37 UTC

Description PURANDHAR SAIRAM MANNIDI 2019-09-09 07:43:48 UTC
Description of problem:
Os-net-config validation throws error when cpu_list parameter is used for vrouter dpdk nic type.

Sep  4 09:00:07 compute1 os-collect-config: [2019/09/04 08:57:03 AM] [WARNING] Config file failed schema validation at network_config/4:
Sep  4 09:00:07 compute1 os-collect-config: {'persist_mapping': False, 'addresses': [{'ip_netmask': '172.16.0.12/23'}], 'cpu_list': '0x1554', 'nic_mapping': None, 'driver': 'vfio-pci', 'mtu': 9000, 'bond_
mode': 4, 'members': [{'type': 'interface', 'name': 'p1p1', 'mtu': 9096}, {'type': 'interface', 'name': 'p1p2', 'mtu': 9096}], 'use_dhcp': False, 'bond_policy': 'layer3+4', 'type': 'contrail_vrouter_dpdk', 'name': 'vhost0'} is not valid under any of the given schemas
Sep  4 09:00:07 compute1 os-collect-config: Sub-schemas tested and not matching:
Sep  4 09:00:07 compute1 os-collect-config: - items/oneOf/contrail_vrouter_dpdk/additionalProperties: Additional properties are not allowed ('cpu_list' was unexpected)

RH OpenStack Platform 13

How reproducible:
Always

Actual results:
os-net-config throws validation error

Expected results:
os-net-config validation should succeed

Additional info:
This should be backport of https://review.opendev.org/#/c/601615/1

Comment 1 PURANDHAR SAIRAM MANNIDI 2019-09-09 07:45:47 UTC
There was a typo with MTU.

Sep  4 09:00:07 compute1 os-collect-config: [2019/09/04 08:57:03 AM] [WARNING] Config file failed schema validation at network_config/4:
Sep  4 09:00:07 compute1 os-collect-config: {'persist_mapping': False, 'addresses': [{'ip_netmask': '172.16.0.12/23'}], 'cpu_list': '0x1554', 'nic_mapping': None, 'driver': 'vfio-pci', 'mtu': 9000, 'bond_
mode': 4, 'members': [{'type': 'interface', 'name': 'p1p1', 'mtu': 9000}, {'type': 'interface', 'name': 'p1p2', 'mtu': 9000}], 'use_dhcp': False, 'bond_policy': 'layer3+4', 'type': 'contrail_vrouter_dpdk', 'name': 'vhost0'} is not valid under any of the given schemas
Sep  4 09:00:07 compute1 os-collect-config: Sub-schemas tested and not matching:
Sep  4 09:00:07 compute1 os-collect-config: - items/oneOf/contrail_vrouter_dpdk/additionalProperties: Additional properties are not allowed ('cpu_list' was unexpected)

Comment 11 Bob Fournier 2019-11-04 17:58:35 UTC
Verified that cpu_list is now used instead of coremask in schema.yaml.

Comment 13 errata-xmlrpc 2019-11-07 14:02:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.