Bug 1750336 - [OSP13] missing share block on uplink interface after reboot (workaround)
Summary: [OSP13] missing share block on uplink interface after reboot (workaround)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z9
: 13.0 (Queens)
Assignee: Saravanan KR
QA Contact: nlevinki
URL:
Whiteboard:
: 1730806 (view as bug list)
Depends On:
Blocks: 1653846 1722635 1731922
TreeView+ depends on / blocked
 
Reported: 2019-09-09 10:53 UTC by Saravanan KR
Modified: 2019-11-07 21:18 UTC (History)
9 users (show)

Fixed In Version: os-net-config-8.4.4-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:02:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 679522 'None' MERGED fix missing shared_block for PF interface in switchdev bond connected to ovs 2020-03-29 23:31:58 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:37 UTC

Description Saravanan KR 2019-09-09 10:53:39 UTC
This bug was initially created as a copy of Bug #1733953

I am copying this bug because: 



Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Reload the driver to clean tc rules
2. tc q | grep ingress (should be empty)
3. enable SR-IOV on both port
4. move port to switchdev mode
5. Start the openvsiwtch
6. Add bond has ovs port
7. tc q | grep ingress (tc shared block apply on the bond0)
[root@overcloud-computesriov-0 ~]# tc q | grep ingress
qdisc ingress ffff: dev bond0 parent ffff:fff1 ----------------
qdisc ingress ffff: dev vxlan_sys_4789 parent ffff:fff1 ----------------
8.  add the ports to bond interface



Actual results:
tc q | grep ingress (tc shared block apply on the bond0)
[root@overcloud-computesriov-0 ~]# tc q | grep ingres
qdisc ingress ffff: dev bond0 parent ffff:fff1 ----------------
qdisc ingress ffff: dev vxlan_sys_4789 parent ffff:fff1 ----------------

Expected results:
[root@overcloud-computesriov-0 ~]# tc q | grep ingres
qdisc ingress ffff: dev bond0 parent ffff:fff1 ----------------
qdisc ingress ffff: dev vxlan_sys_4789 parent ffff:fff1 -----------
qdisc ingress ffff: dev enp3s0f0  parent ffff:fff1 ---------------- 
qdisc ingress ffff: dev enp3s0f1 parent ffff:fff1 -------------


Additional info:

Comment 8 Saravanan KR 2019-10-30 09:29:55 UTC
*** Bug 1730806 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2019-11-07 14:02:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.