Bug 1750387 - Deprecated log rotate command still present in "# gluster v help"
Summary: Deprecated log rotate command still present in "# gluster v help"
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kshithij Iyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1784415
TreeView+ depends on / blocked
 
Reported: 2019-09-09 13:48 UTC by Kshithij Iyer
Modified: 2019-12-17 11:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1784415 (view as bug list)
Environment:
Last Closed: 2019-12-17 11:33:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23392 None Merged [Cli] Removing old log rotate command. 2019-12-17 11:33:49 UTC

Description Kshithij Iyer 2019-09-09 13:48:10 UTC
Description of problem:
{"volume log rotate <VOLNAME> [BRICK]", cli_cmd_log_rotate_cbk,
 "rotate the log file for corresponding volume/brick"
 " NOTE: This is an old syntax, will be deprecated from next release."},

Should be removed from cli-cmd-volume.c as the command seems to be depreciated now.

Version-Release number of selected component (if applicable):
Whatever is the latest version.

How reproducible:
Always

Steps to Reproduce:
1.Run # gluster v help on a gluster cluster.

Actual results:
Command is displayed in the help menu.

Expected results:
Command should not be a part of the help menu.

Additional info:

Comment 1 Worker Ant 2019-09-09 13:58:12 UTC
REVIEW: https://review.gluster.org/23392 ([Cli] Removing old log rotate command from \"# gluster v help\".) posted (#1) for review on master by Kshithij Iyer

Comment 2 Sanju 2019-11-19 12:26:30 UTC
Kshithij, would you like to work on the fix for this?

Comment 3 Kshithij Iyer 2019-11-19 13:10:14 UTC
Yes! I would like to give it a try.

Comment 4 Worker Ant 2019-12-17 11:33:50 UTC
REVIEW: https://review.gluster.org/23392 ([Cli] Removing old log rotate command.) merged (#16) on master by Sunny Kumar


Note You need to log in before you can comment on or make changes to this bug.