Bug 1750394 - Gnome Control Center crashes upon a typo in Printers settings
Summary: Gnome Control Center crashes upon a typo in Printers settings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pete Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeExcepti...
Depends On:
Blocks: BetaFreezeException, F31BetaFreezeException F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-09 14:03 UTC by Lukas Ruzicka
Modified: 2019-10-10 18:27 UTC (History)
10 users (show)

Fixed In Version: gnome-control-center-3.34.1-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 18:27:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-control-center/issues/679 None None None 2019-09-18 15:35:27 UTC

Description Lukas Ruzicka 2019-09-09 14:03:13 UTC
Description of problem:

I want to configure a remote printer on my Fedora 31 system. On this machine, I am using the US keyboard layout, which I am not used to, so I produce a lot of typos. Such a typo prevents me from adding a new remote printer to the system.

Version-Release number of selected component (if applicable):

gnome-control-center-3.33.90-1.fc31.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Start Gnome-Control-Center.
2. Navigate to Devices - Printers.
3. Click "Add"
4. Type "socket>" into the search field (another string like "socket#" works too).
5. Application crashes with an error.

Actual results:

The application crashes with the above non-sense written in the search field.

Expected results:

The application lets the user correct any typos that they might have produced while typing.

Additional info:

Without the typo, when I write "socket:", the application behaves as expected.

===== The reported error: ======
    GLib-GIO-WARNING **: 15:43:09.523: Invalid URI 'none://socket>:9100'
    ​
    (gnome-control-center:11183): GLib-GIO-WARNING **: 15:43:09.523: Invalid URI 'none://socket>:515'
    ​
    (gnome-control-center:11183): GLib-Net-CRITICAL **: 15:43:09.524: g_proxy_resolver_gnome_lookup_finish: assertion 'g_task_get_source_tag (G_TASK (result)) == g_proxy_resolver_gnome_lookup_async' failed
    Segmentation fault (core dumped)

Comment 1 Fedora Blocker Bugs Application 2019-09-09 14:05:48 UTC
Proposed as a Blocker for 31-beta by Fedora user lruzicka using the blocker tracking app because:

 I know that this is somehow weak, but I am suggesting it as a blocker, because Gnome-Control-Center is a "core application" and behaviour like that is really annoying.

Comment 2 Geoffrey Marr 2019-09-09 19:08:52 UTC
Discussed during the 2019-09-09 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" and an "AcceptedBlocker" was made as it violates the following criterion:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"

We accept this as an FE as long as the fix is clean.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-09/f31-blocker-review.2019-09-09-16.00.txt

Comment 3 Michael Catanzaro 2019-09-14 15:12:37 UTC
This needs to be reported upstream.

Comment 4 Lukas Ruzicka 2019-09-18 14:09:17 UTC
Where exactly, please?

Comment 5 Lukas Ruzicka 2019-09-18 14:13:23 UTC
Found it, https://gitlab.gnome.org/GNOME/gnome-control-center/issues/679

Comment 6 Adam Williamson 2019-10-02 18:01:20 UTC
The fix for this has been merged upstream, we should pull it downstream now.

Comment 7 Fedora Update System 2019-10-02 18:27:31 UTC
FEDORA-2019-be95719373 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-be95719373

Comment 8 Fedora Update System 2019-10-03 03:20:02 UTC
gnome-control-center-3.34.0.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-be95719373

Comment 9 Kamil Páral 2019-10-03 08:54:34 UTC
Well, the dialog no longer crashes. But that's because the whole search box is now non-functional. I can no longer search for printers at my company's CUPS server. Previously, when I input "cups.brq.redhat.com" into the search field, a "Searching for printers" text appeared in the dialog title and my company printers appeared. Now when I input the same string, there is no "Searching for printers" displayed and nothing happens, no printers appear. There is nothing printed into the system journal. The search bar now seems completely dead, not sending any events. That doesn't feel like an improvement from the previous state :-)

Comment 10 Lukas Ruzicka 2019-10-03 10:50:41 UTC
Yes, same situation happens for me, however I am not even getting the "Searching for printers" text after the first searching takes place.

When I click on ADD, it starts to search for the printers in my neighbourhood and comes up with some PDF printers taken from my own cups server, but when I use the box to write an address where to search for more and press ENTER, nothing really happens.

I am on gnome-control-center-3.34.0.1-2.fc31.x86_64.

Comment 11 Fedora Update System 2019-10-09 12:13:26 UTC
FEDORA-2019-8f20f9e4e3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f20f9e4e3

Comment 12 Fedora Update System 2019-10-09 23:05:30 UTC
accerciser-3.34.1-1.fc31, almanah-0.12.0-1.fc31, at-spi2-atk-2.34.1-1.fc31, eog-3.34.1-1.fc31, epiphany-3.34.1-1.fc31, evince-3.34.1-1.fc31, evolution-3.34.1-1.fc31, evolution-data-server-3.34.1-1.fc31, evolution-ews-3.34.1-1.fc31, evolution-mapi-3.34.1-1.fc31, four-in-a-row-3.34.1-1.fc31, gdk-pixbuf2-2.40.0-1.fc31, gdm-3.34.1-1.fc31, geary-3.34.1-2.fc31, gjs-1.58.1-1.fc31, glib-networking-2.62.1-1.fc31, glib2-2.62.1-1.fc31, gnome-2048-3.34.1-1.fc31, gnome-boxes-3.34.1-1.fc31, gnome-builder-3.34.1-1.fc31, gnome-calculator-3.34.1-1.fc31, gnome-calendar-3.34.1-1.fc31, gnome-control-center-3.34.1-3.fc31, gnome-desktop3-3.34.1-1.fc31, gnome-initial-setup-3.34.1-1.fc31, gnome-maps-3.34.1-1.fc31, gnome-session-3.34.1-2.fc31, gnome-shell-3.34.1-1.fc31, gnome-shell-extensions-3.34.1-1.fc31, gnome-software-3.34.1-1.fc31, gnome-taquin-3.34.1-1.fc31, gnome-terminal-3.34.1-1.fc31, gnome-tetravex-3.34.1-1.fc31, gpaste-3.34.1-1.fc31, gtk3-3.24.12-1.fc31, gvfs-1.42.1-1.fc31, iagno-3.34.1-1.fc31, libdazzle-3.34.1-1.fc31, libgweather-3.34.0-1.fc31, librsvg2-2.46.1-1.fc31, libsoup-2.68.2-1.fc31, mutter-3.34.1-1.fc31, nautilus-3.34.1-1.fc31, quadrapassel-3.34.1-1.fc31, simple-scan-3.34.1-1.fc31, sysprof-3.34.1-1.fc31, totem-3.34.1-1.fc31, vala-0.46.3-1.fc31, vte291-0.58.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f20f9e4e3

Comment 13 Felipe Borges 2019-10-10 09:11:42 UTC
gnome-control-center-3.34.1-3.fc31 ships a downstream patch with a fix for this bug.

Comment 14 František Zatloukal 2019-10-10 13:08:48 UTC
Yes, gnome-control-center-3.34.1-3 fixes the issue.

Comment 15 Fedora Update System 2019-10-10 18:27:07 UTC
accerciser-3.34.1-1.fc31, almanah-0.12.0-1.fc31, at-spi2-atk-2.34.1-1.fc31, eog-3.34.1-1.fc31, epiphany-3.34.1-1.fc31, evince-3.34.1-1.fc31, evolution-3.34.1-1.fc31, evolution-data-server-3.34.1-1.fc31, evolution-ews-3.34.1-1.fc31, evolution-mapi-3.34.1-1.fc31, four-in-a-row-3.34.1-1.fc31, gdk-pixbuf2-2.40.0-1.fc31, gdm-3.34.1-1.fc31, geary-3.34.1-2.fc31, gjs-1.58.1-1.fc31, glib-networking-2.62.1-1.fc31, glib2-2.62.1-1.fc31, gnome-2048-3.34.1-1.fc31, gnome-boxes-3.34.1-1.fc31, gnome-builder-3.34.1-1.fc31, gnome-calculator-3.34.1-1.fc31, gnome-calendar-3.34.1-1.fc31, gnome-control-center-3.34.1-3.fc31, gnome-desktop3-3.34.1-1.fc31, gnome-initial-setup-3.34.1-1.fc31, gnome-maps-3.34.1-1.fc31, gnome-session-3.34.1-2.fc31, gnome-shell-3.34.1-1.fc31, gnome-shell-extensions-3.34.1-1.fc31, gnome-software-3.34.1-1.fc31, gnome-taquin-3.34.1-1.fc31, gnome-terminal-3.34.1-1.fc31, gnome-tetravex-3.34.1-1.fc31, gpaste-3.34.1-1.fc31, gtk3-3.24.12-1.fc31, gvfs-1.42.1-1.fc31, iagno-3.34.1-1.fc31, libdazzle-3.34.1-1.fc31, libgweather-3.34.0-1.fc31, librsvg2-2.46.1-1.fc31, libsoup-2.68.2-1.fc31, mutter-3.34.1-1.fc31, nautilus-3.34.1-1.fc31, quadrapassel-3.34.1-1.fc31, simple-scan-3.34.1-1.fc31, sysprof-3.34.1-1.fc31, totem-3.34.1-1.fc31, vala-0.46.3-1.fc31, vte291-0.58.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.