Bug 1750450 - Lightning not working in SeaMonkey 2.49.5 due to --disable-calendar
Summary: Lightning not working in SeaMonkey 2.49.5 due to --disable-calendar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: seamonkey
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-09 15:49 UTC by A. Galama
Modified: 2019-09-28 00:01 UTC (History)
5 users (show)

Fixed In Version: seamonkey-2.49.5-2.fc30 seamonkey-2.49.5-2.fc29 seamonkey-2.49.5-2.el7 seamonkey-2.49.5-2.el6 seamonkey-2.49.5-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-19 01:29:54 UTC
Type: Bug


Attachments (Terms of Use)

Description A. Galama 2019-09-09 15:49:55 UTC
Description of problem:
The Lightning and Lightbird add-on does not work with seamonkey-2.49.5-1 because SeaMonkey was configured with --disable-calendar. Instead it must be configured with --enable-calendar. See: https://groups.google.com/d/msg/mozilla.support.seamonkey/DWj2unF91to/HGyqasDkAgAJ


Version-Release number of selected component (if applicable):
seamonkey-2.49.5-1.fc30.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install seamonkey-2.49.5-1.fc30.x86_64
2. Install Lightning or Lightbird add-on
3. Open the Lightnin or Lightbird calendar

Actual results:
Blank window with Lightning, error message with Lightbird.

Expected results:
Calendar shows and is usable.

Additional info:
See also https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f7489dc8c

Comment 1 Dmitry Butskoy 2019-09-09 21:11:24 UTC
Please test new build:
https://kojipkgs.fedoraproject.org//packages/seamonkey/2.49.5/2.fc30/x86_64/seamonkey-2.49.5-2.fc30.x86_64.rpm
It does not provide its own bundled lightning, but all the needed things should be compiled in. If it does not work, try to play with emptying profiles etc...

Comment 2 michiel 2019-09-09 21:55:26 UTC
works for me

Comment 3 Fedora Update System 2019-09-09 22:56:22 UTC
FEDORA-2019-92bd15f74a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-92bd15f74a

Comment 4 Fedora Update System 2019-09-09 22:56:56 UTC
FEDORA-2019-ea200bba7e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ea200bba7e

Comment 5 Fedora Update System 2019-09-09 22:57:36 UTC
FEDORA-2019-763a99010a has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-763a99010a

Comment 6 Fedora Update System 2019-09-10 14:32:17 UTC
seamonkey-2.49.5-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-92bd15f74a

Comment 7 A. Galama 2019-09-10 20:28:50 UTC
Lightning works now, but with Lightbird I still get:

XML Parsing Error: undefined entity
Location: chrome://lightbird/content/sunbird/calendar.xul
Line Number 53, Column 1:

<window id="calendar-window"
^

Comment 8 Fedora Update System 2019-09-11 02:58:46 UTC
seamonkey-2.49.5-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ea200bba7e

Comment 9 Fedora Update System 2019-09-11 04:16:57 UTC
seamonkey-2.49.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-763a99010a

Comment 10 Dmitry Butskoy 2019-09-11 16:29:47 UTC
People report that lightbird works with updated seamonkey-2.49.5-2, see
https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f7489dc8c#comment-1036822

Certainly you should install external lightning addons first, since the bundled lightning extension itself is not provided (as in 2.49.4 and before).

Comment 11 A. Galama 2019-09-11 17:10:18 UTC
Yes, I had to install Lightning first, then Lightbird works for me too.

Comment 12 Fedora Update System 2019-09-11 23:56:24 UTC
FEDORA-EPEL-2019-57cf200dc6 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-57cf200dc6

Comment 13 Fedora Update System 2019-09-11 23:57:14 UTC
FEDORA-EPEL-2019-04a99d9149 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-04a99d9149

Comment 14 Fedora Update System 2019-09-12 21:41:26 UTC
seamonkey-2.49.5-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-04a99d9149

Comment 15 Fedora Update System 2019-09-12 21:41:46 UTC
seamonkey-2.49.5-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-57cf200dc6

Comment 16 Fedora Update System 2019-09-19 01:29:54 UTC
seamonkey-2.49.5-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-09-19 01:52:40 UTC
seamonkey-2.49.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-09-27 00:25:16 UTC
seamonkey-2.49.5-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-09-27 00:52:13 UTC
seamonkey-2.49.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2019-09-28 00:01:56 UTC
seamonkey-2.49.5-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.