Bug 175052 - Camera plugin doesn't cause camera:/ popup under KDE
Camera plugin doesn't cause camera:/ popup under KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 19:47 EST by Jesse Barnes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1.99-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 02:22:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Barnes 2005-12-05 19:47:09 EST
I have a libusb based camera that I use under KDE.  It works fine (i.e. I can 
plug it in and open Konqueror with camera:/ and get to the pictures), except 
for the fact that I never get a popup message when the camera is first plugged 
in.  Ideally, I'd like to have it behave similarly to what happens when I plug 
my compact flash reader in--a window with the contents of the drive pops up 
automatically, making it very easy to use.  Is this a known problem?
Comment 1 Jesse Barnes 2006-01-06 16:37:18 EST
More info on this.  I did a little digging to see if dbus events were properly 
generated when my camera is plugged in; they are.  So it seems that we just 
need a small tweak to one of the hal .fdi files somewhere to cause a konqueror 
window with the appropriate camera:/ url to popup (or maybe some kdelibs 
hacking, not sure). 
Comment 2 Jesse Barnes 2006-01-06 18:12:04 EST
Looks like this may be a gphoto2 problem, apparently the script used to  
generate the .fdi file for gphoto2 supported cameras isn't setting the  
libgphoto2.support property to 'true' as it should.  The gphoto2 tarball 
contains an updated script to generate this file.  
Comment 3 David Zeuthen 2006-01-06 18:20:49 EST
(reassigning to gphoto2 package owner)

The SUSE gphoto2 SRPM is reported to do the right thing (though I haven't looked
at it). It's available here
 http://ftp.opensuse.org/pub/opensuse/distribution/SL-OSS-factory/inst-source/suse/src/gphoto-2.1.99head-4.src.rpm

Cheers,
David
Comment 4 Jesse Barnes 2006-01-07 00:06:24 EST
Ah, the problem appears to be bigger than just gphoto.  It looks like KDE 
isn't built with HAL support at all at this point, maybe because the dbus-qt 
bindings have been removed? 
Comment 5 David Zeuthen 2006-01-08 12:49:13 EST
Suggest to open a new bug against KDE for building it with HAL support
Comment 6 Radek Vokal 2006-01-23 07:17:38 EST
dbus-qt will be hopefully back soon
Comment 7 David Zeuthen 2006-01-23 09:25:06 EST
Not sure about d-bus qt coming back (they moved qt3 sources to KDE SVN btw),
seems like a separate dbus bug... The real bug with gphoto2 here is expressed in
comment 3 so I'm reassigning this back to gphoto2 so it will get fixed. Thanks.
Comment 8 David Zeuthen 2006-01-23 09:26:02 EST
Ugh, forgot to reassign to pkg owner (see comment 7).
Comment 9 Radek Vokal 2006-01-23 09:57:39 EST
(In reply to comment #7)
> Not sure about d-bus qt coming back (they moved qt3 sources to KDE SVN btw),

https://www.redhat.com/archives/fedora-devel-list/2006-January/msg01137.html

Comment 10 Jesse Barnes 2006-02-24 21:58:27 EST
This works now, though the /proc/bus/usb permissions are wrong, so the 
camera:/ kioslave fails.  I think this is a gphoto problem though, so this bug 
can be closed. 
Comment 11 Radek Vokal 2006-02-27 02:22:01 EST
gphoto2 now changes the permissions of /proc/bus/usb. I believe this is fixed now. 

Note You need to log in before you can comment on or make changes to this bug.