Bug 175063 - entry with escaped characters fails to import and index
entry with escaped characters fails to import and index
Status: CLOSED ERRATA
Product: Red Hat Directory Server
Classification: Red Hat
Component: Database - Import/Export (Show other bugs)
7.2
All Linux
medium Severity medium
: DS8.0
: ---
Assigned To: Noriko Hosoi
Orla Hegarty
:
Depends On:
Blocks: 152373 159328 182367 182630 184343 240316
  Show dependency treegraph
 
Reported: 2005-12-05 21:49 EST by Noriko Hosoi
Modified: 2008-08-11 19:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 13:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test data to reproduce the problem (15.89 KB, text/plain)
2005-12-05 22:01 EST, Noriko Hosoi
no flags Details
cvs diff slapd/back-ldbm/{import.c,import-threads.c,import.h} (3.05 KB, patch)
2005-12-05 22:04 EST, Noriko Hosoi
no flags Details | Diff
cvs commit message (838 bytes, text/plain)
2005-12-06 13:25 EST, Noriko Hosoi
no flags Details
sample ldif file (suffix: dc=sfbay,dc=redhat,dc=com) with ugly DNs (16.06 KB, text/plain)
2005-12-07 19:46 EST, Noriko Hosoi
no flags Details
cvs diff dn.c (1.26 KB, patch)
2005-12-07 19:48 EST, Noriko Hosoi
no flags Details | Diff
cvs commit dn.c (481 bytes, text/plain)
2005-12-07 19:56 EST, Noriko Hosoi
no flags Details
cvs commit message (Directory71RtmBranch) (992 bytes, text/plain)
2006-02-20 13:16 EST, Noriko Hosoi
no flags Details

  None (edit)
Comment 2 Noriko Hosoi 2005-12-05 22:04:09 EST
Created attachment 121886 [details]
cvs diff slapd/back-ldbm/{import.c,import-threads.c,import.h}

If missing entry_id is found, skip it and continue reading the primary db to be
reindexed.
Comment 3 Noriko Hosoi 2005-12-06 13:04:10 EST
How to verify the bug:
1. import an ldif file
2. remove some entries
3. run db2index

Actual results:
db2index fails with this "foreman fifo error"
[06/Dec/2005:09:44:41 -0800] - import userRoot: ERROR: foreman fifo error
[06/Dec/2005:09:44:41 -0800] - import userRoot: Aborting all import threads...

Expected results:
db2index should finish w/o any error.



Comment 4 Noriko Hosoi 2005-12-06 13:25:44 EST
Created attachment 121929 [details]
cvs commit message

Reviewed by Rich (Thank you!).
Comment 8 Noriko Hosoi 2005-12-07 19:51:29 EST
As Rich suggested, ran Accountinact and Pwdpolicy testcases and passed 100% (on
RHEL4).
Comment 9 Noriko Hosoi 2005-12-07 19:56:52 EST
Created attachment 122016 [details]
cvs commit dn.c

Reviewed by Rich (Thank you!)
Comment 10 Noriko Hosoi 2006-02-20 13:16:28 EST
Created attachment 124891 [details]
cvs commit message (Directory71RtmBranch)
Comment 11 Noriko Hosoi 2006-03-08 19:31:32 EST
*DOCS*
When an ldif file contains an entry with the dn that includes escaped double
quotes, importing the entry could have failed and the entry is skipped. 
Following reindex fails due to the skip.  The bug was fixed on DS6.21 SP3, DS7.1
SP2(, and DS7.2).
Comment 12 Orla Hegarty 2006-03-10 20:40:19 EST
New regression testcase added to the import test plan and run as part of the
daily acceptance test suite. Verified fixed on all supported platforms ( RHEL 3
and 4, Solaris 9 32 bit and 64 bit, and HP-UX 11i ) against DS 7.1 SP 2 
Comment 13 To Ngan 2006-03-14 19:58:43 EST
Ported Import TET case and verified against DS 6.21 SP3 candidate 20060310.1
Comment 15 Orla Hegarty 2006-05-26 13:46:51 EDT
Somehow the errata system did not automatically close these bugs even though DS
SP 2 is shipped and available live on RHN
Comment 16 Chandrasekar Kannan 2007-07-25 15:00:58 EDT
DS7.2 is not a valid milestone anymore. Anything thats set to DS7.2 should be
set to DS8.0. Will make further changes per bug council on 07/24/2007, after this.
Comment 17 Chandrasekar Kannan 2008-08-11 19:43:04 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.