Bug 175066 - bind update wants to overwrite /etc/rndc.key (a symlink) with a file
bind update wants to overwrite /etc/rndc.key (a symlink) with a file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 23:57 EST by Stephen Warren
Modified: 2008-05-09 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 16:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2005-12-05 23:57:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
I have bind and bind-chroot installed. Consequently, /etc/rndc.key is a symlink to /var/named/chroot/etc/rndc.key.

When I "yum update" to the bind version listed above (starting with whatever was in fc5t1), it creates a file /etc/rndc.key.rpmnew. Obviously, rpm wanted to replace /etc/rndc.key with a new file, but didn't because it found a modification - the modification being the bind-chroot install?

I'm not 100% sure this is a bug - perhaps it's normal... If so, sorry for wasting your time!

But, I would expect some kind of interaction between bind/bind-chroot so that updates of bind never attempt to overwrite/recreate /etc/rndc.key?

Also, the file /etc/rndc.key.rpmnew didn't have the @KEY@ template token replaced. Not sure how/when that happens, but could be a bug?


Version-Release number of selected component (if applicable):
bind-9.3.2rc1-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Install fc5t1
2. yum update
3. watch for warning/error messages

Additional info:
Comment 1 Jason Vas Dias 2005-12-07 12:08:02 EST
Yes, this is a buglet, but it is not simple to fix, and has no problematic
consequences.
We want rndc.key to be "owned" by bind - so it is in the .spec file as 
"%config(noreplace) /etc/rndc.key" - so you can modify it and your 
modifications will not be lost during upgrades.
The very first time bind is installed, it replaces the "@KEY@" template 
in rndc.key with the output of a /usr/sbin/dns-keygen run - so the file
is already modified from its default contents, and subject to treatment
as a modified config file by rpm - so rpm will install new versions of
rndc.key during upgrades as rndc.key.rpmnew .  

Note You need to log in before you can comment on or make changes to this bug.