Bug 1750744 - Fix issues on Big Endian
Summary: Fix issues on Big Endian
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: conntrack-tools
Version: 8.2
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Phil Sutter
QA Contact: Jianwen Ji
URL:
Whiteboard:
: 1748289 (view as bug list)
Depends On: 1679372 1750626
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-10 12:13 UTC by Phil Sutter
Modified: 2020-04-28 16:52 UTC (History)
3 users (show)

Fixed In Version: conntrack-tools-1.4.4-10.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1750626
Environment:
Last Closed: 2020-04-28 16:52:32 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1846 None None None 2020-04-28 16:52:33 UTC

Comment 1 Phil Sutter 2019-09-10 13:17:19 UTC
Use this ticket to consolidate conntrack-tools issues on Big Endian architectures for RHEL8. So far, there is one upstream commit to backport:

commit f27901afb038b07532b4c31cb77bbc0bd8068253
Author: Phil Sutter <phil@nwl.cc>
Date:   Mon Sep 2 18:39:51 2019 +0200

    conntrack: Fix CIDR to mask conversion on Big Endian
    
    Code assumed host architecture to be Little Endian. Instead produce a
    proper mask by pushing the set bits into most significant position and
    apply htonl() on the result.
    
    Fixes: 3f6a2e90936bb ("conntrack: add support for CIDR notation")
    Signed-off-by: Phil Sutter <phil@nwl.cc>
    Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>

and one more fix not yet accepted:

https://lore.kernel.org/netfilter-devel/20190910120631.20817-1-phil@nwl.cc/T/#u

Comment 2 Phil Sutter 2019-11-18 12:16:22 UTC
Second upstream commit to backport:

commit 7c5f4b390f4b8dc02aceb0a18ed7c59ff14f392c
Author: Phil Sutter <phil@nwl.cc>
Date:   Tue Sep 10 14:02:30 2019 +0200

    nfct: helper: Fix NFCTH_ATTR_PROTO_L4NUM size
    
    Kernel defines NFCTH_TUPLE_L4PROTONUM as of type NLA_U8. When adding a
    helper, NFCTH_ATTR_PROTO_L4NUM attribute is correctly set using
    nfct_helper_attr_set_u8(), though when deleting
    nfct_helper_attr_set_u32() was incorrectly used. Due to alignment, this
    causes trouble only on Big Endian.
    
    Fixes: 5e8f64f46cb1d ("conntrackd: add cthelper infrastructure (+ example FTP helper)")
    Signed-off-by: Phil Sutter <phil@nwl.cc>
    Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>

Comment 3 Phil Sutter 2019-11-18 13:05:20 UTC
*** Bug 1748289 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-04-28 16:52:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1846


Note You need to log in before you can comment on or make changes to this bug.