Bug 1750805 - Apply button stays gray on Network configuration
Summary: Apply button stays gray on Network configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-10 13:54 UTC by Alessio
Modified: 2019-10-07 00:02 UTC (History)
9 users (show)

Fixed In Version: gnome-control-center-3.34.0.1-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-07 00:02:13 UTC


Attachments (Terms of Use)
gui screenshot (68.70 KB, image/png)
2019-09-10 14:10 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-control-center/issues/677 None None None 2019-09-20 18:36:21 UTC

Description Alessio 2019-09-10 13:54:53 UTC
Tested on Live
Fedora-Workstation-Live-x86_64-31-20190909.n.0.iso
Fedora-Workstation-Live-x86_64-31-20190907.n.0.iso
Fedora-Workstation-Live-x86_64-31-20190905.n.0.iso
and also 
Fedora-Workstation-Live-x86_64-31-20190826.n.0.iso

As well as on a fully updated installation (performed yesterday with an everything netinstall).

Going to network configuration, any performed configuration can't be applyed because the "Apply" button stays gray and can't be pressed.

FWIW nmcli works

Comment 1 Kamil Páral 2019-09-10 14:10:21 UTC
Created attachment 1613604 [details]
gui screenshot

I can confirm this, Apply button is grayed out and can't be used. It only affects the wired network configuration, wifi configs can be adjusted normally. Tested bare metal and a VM.

NetworkManager-1.20.0-3.fc31.x86_64
gnome-control-center-3.33.90-1.fc31.x86_64

Comment 2 Kamil Páral 2019-09-10 14:11:41 UTC
Proposing as a blocker due to:
"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use. "
https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria#Default_panel_functionality

Comment 3 Michael Catanzaro 2019-09-14 15:12:54 UTC
This needs to be reported upstream.

Comment 4 Kamil Páral 2019-09-16 15:23:02 UTC
I usually have the approach of reporting things to RH Bugzilla if I need to mark it as a blocker, and if it gets accepted, we need to contact the developers anyway, so they'll know (and having extra tickets is just needless work). If it is not accepted as a blocker, then it makes sense to forward the ticket to upstream, so that this gets fixed long-term.

Comment 5 Geoffrey Marr 2019-09-16 18:24:45 UTC
Discussed during the 2019-09-16 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-16/f31-blocker-review.2019-09-16-16.02.txt

Comment 6 Ben Cotton 2019-09-20 18:36:21 UTC
Upstream bug report is https://gitlab.gnome.org/GNOME/gnome-control-center/issues/677

Comment 7 Fedora Update System 2019-10-05 15:46:47 UTC
FEDORA-2019-b5fa4a709a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5fa4a709a

Comment 8 Fedora Update System 2019-10-06 02:46:51 UTC
gnome-control-center-3.34.0.1-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5fa4a709a

Comment 9 Alessio 2019-10-06 07:53:04 UTC
It works. Thanks.
Karma added.

Comment 10 Fedora Update System 2019-10-07 00:02:13 UTC
gnome-control-center-3.34.0.1-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.