Bug 17509 - socket: Too many open files in system
Summary: socket: Too many open files in system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-14 17:46 UTC by cwilliams
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 17:46:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cwilliams 2000-09-14 17:46:00 UTC
On a regular basis now, I get the errors listed below:
I only have 10 users on this box all using the Exceed X emulator to gain 
access from their desktop NT's.  I have 3 samba connections between and NT 
domain, and this is a dual processor PC with the kernel configured for 
SMP.  3 10/100 NIC cards and 2 1000 NIC cards are installed in addition to 
the standard PC hardware.  Do you guys have any clue whye I get these 
errors periodically?

Thanks

Curtis Williams

[systemtest@test-rtr systemtest]$ ping 192.168.101.2
socket: Too many open files in system
[systemtest@test-rtr systemtest]$ top
top: error in loading shared libraries: libproc.so.2.0.6: cannot open 
shared object file: Error 23
[systemtest@test-rtr systemtest]$ 
[systemtest@test-rtr systemtest]$ ps aux | less
less: error in loading shared libraries: libncurses.so.4: cannot open 
shared object file: Error 23
Segmentation fault
[systemtest@test-rtr systemtest]$ 
[systemtest@test-rtr systemtest]$ su -
su: user root does not exist
[systemtest@test-rtr systemtest]$ su -
su: user root does not exist
[systemtest@test-rtr systemtest]$ ps aux
ps: error in loading shared libraries: libproc.so.2.0.6: cannot open 
shared object file: Error 23
[systemtest@test-rtr systemtest]$ ls
ls: error in loading shared libraries: libtermcap.so.2: cannot open shared 
object file: Error 23
[systemtest@test-rtr systemtest]$

Comment 1 Alan Cox 2000-09-15 17:09:07 UTC
It looks like you are running out of file handles. The default should be enough
for users but can be increased by doing

echo "65536" >/proc/sys/inode-max
echo "16384" >/proc/sys/file-max

Putting these lines at the end of /etc/rc.d/rc.local will cause them to be run
every further boot up.

Looking at

ls /proc/*/fd can be instructive in seeing which process ids are using a lot of
files if that doesnt help or an application continues to eat them all.



Note You need to log in before you can comment on or make changes to this bug.