Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1750906 - Can't scroll to the bottom of the Installed Operator list with an operator installed in all namespaces
Summary: Can't scroll to the bottom of the Installed Operator list with an operator in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-10 17:33 UTC by Mike Fiedler
Modified: 2019-10-16 06:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:40:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2715 0 None None None 2019-09-13 17:48:49 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:41:04 UTC

Description Mike Fiedler 2019-09-10 17:33:18 UTC
Description of problem:

My cluster has about 50 projects.  I installed the elasticsearch 4.2 operator in all namespaces .   Visiting the Installed Opertators selection and trying to scroll to the bottom of the list fails.

Chrome 76.0.3809.21:  The scrollbar hits the bottom of the list and bounces back up approximately 10 entries.

Firefox 68.0.2:  The scrollbar hits the bottom of the list and the main display where operators should be listed goes blank.   Attempting to scroll up returns to the bottom of the blank list.


Version-Release number of selected component (if applicable): 


How reproducible: 4.2.0-0.nightly-2019-09-10-074025


Steps to Reproduce:
1.  Add 10-20 projects to a default install
2.  Install the ES 4.2 operator in all namespaces
3.  Go to Operators -> Installed operators
4.  Try to scroll to the bottom of the list


Actual results:

See above, a bit different for Chrome and FF


Additional Info:

No errors on the Console or Network in dev tools for the browser.

Comment 3 Fan Jia 2019-09-12 02:38:35 UTC
test env:
cv:4.2.0-0.nightly-2019-09-11-202233
console commit:ed6c3ebf69e77a4c9981915b77db366199016e48

test result:
install one operator "amq" to `all-namespaces` and wait for the "copied" finished, click "Installed Operators" and choose "Project:all-projects"

CHROM: The scrollbar hits the bottom of the list and bounces back up approximately 10 entries.
FF: The scrollbar hits the bottom of the list and bounces back up approximately 10 entries.

ps: If you search the key word "amq" of this page will find that the number of "amq" is not stable will switch between 8 and 17.

Comment 7 Samuel Padgett 2019-09-13 18:36:39 UTC
Fixed by https://github.com/openshift/console/pull/2715

Note that new rows added above will still push content down. But we preserve scroll position, and the page doesn't jump when existing rows change.

Comment 9 XiaochuanWang 2019-09-16 02:15:03 UTC
Check on Firefox 68 and Chorme 76, both are not reproduced.
Verified on 4.2.0-0.nightly-2019-09-15-052022

Comment 10 errata-xmlrpc 2019-10-16 06:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.