Bug 1751004 - Log Settings "Create New Log Every" takes non integer as input, it even takes alphabets
Summary: Log Settings "Create New Log Every" takes non integer as input, it even takes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: dirsrv-11.1
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 02:36 UTC by Anuj Borah
Modified: 2020-04-29 08:04 UTC (History)
7 users (show)

Fixed In Version: 389-ds-base-1.4.2.8-2.module+el8dsrv+5809+6657a82a
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-29 08:04:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
SS (371.20 KB, video/webm)
2019-09-11 02:36 UTC, Anuj Borah
no flags Details
Recording (2.83 MB, video/webm)
2019-10-01 07:48 UTC, Viktor Ashirov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1961 0 None None None 2020-04-29 08:04:48 UTC

Description Anuj Borah 2019-09-11 02:36:16 UTC
Created attachment 1613876 [details]
SS

Description of problem:

Server Settings > Logging > Access Log > Rotation Policy >  Create New Log Every
Server Settings > Logging > Audit Log  > Rotation Policy >  Create New Log Every
Server Settings > Logging > Audit Failure Log > Rotation Policy >  Create New Log Every
Server Settings > Logging > Error Log > Rotation Policy >  Create New Log Every


Version-Release number of selected component (if applicable):
389-ds-base-1.4.1.8-1.module+el8dsrv+4209+f45880df.x86_64


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Viktor Ashirov 2019-10-01 07:47:29 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

Issue is still present. I can enter non-numeric symbols and save the configuration. I get an error, but the error message contents is missing.
I'm attaching recording of the issue.

Moving to ASSIGNED.

Comment 3 Viktor Ashirov 2019-10-01 07:48:37 UTC
Created attachment 1621333 [details]
Recording

Comment 5 mreynolds 2019-11-08 22:03:15 UTC
https://pagure.io/389-ds-base/issue/50696

Comment 7 Viktor Ashirov 2020-02-17 13:55:03 UTC
Build tested: 389-ds-base-1.4.2.7-1.module+el8dsrv+5547+8be68086.x86_64

The issue is still present: input fields do not do any validation.

Moving to ASSIGNED.

Comment 8 Viktor Ashirov 2020-03-02 15:15:35 UTC
Builds tested:
389-ds-base-1.4.2.8-2.module+el8dsrv+5809+6657a82a.x86_64
cockpit-389-ds-1.4.2.8-2.module+el8dsrv+5809+6657a82a.noarch

Log settings fields are sanitized. Marking as VERIFIED.

Comment 10 errata-xmlrpc 2020-04-29 08:04:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1961


Note You need to log in before you can comment on or make changes to this bug.