Bug 1751011 - DS instance can be easily destroyed by changing non existing Directory Manager DN
Summary: DS instance can be easily destroyed by changing non existing Directory Manage...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: cockpit-389-ds
Version: 11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: dirsrv-11.1
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 03:20 UTC by Anuj Borah
Modified: 2020-04-29 08:04 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.4.2.7-1.module+el8dsrv+5547+8be68086
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-29 08:04:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Video1 (1.33 MB, video/webm)
2019-09-11 03:20 UTC, Anuj Borah
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1961 0 None None None 2020-04-29 08:04:48 UTC

Description Anuj Borah 2019-09-11 03:20:34 UTC
Created attachment 1613882 [details]
Video1

Description of problem:

DS instance can be easily destroyed by changing non existing Directory Manager DN 
DS should not allow users to make changes with non existing  Directory Manager DN

Server Settings > Server Configuration > Directory Manager DN

Change DN with a non existing name


Version-Release number of selected component (if applicable):
389-ds-base-1.4.1.8-1.module+el8dsrv+4209+f45880df.x86_64


How reproducible:
Always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 mreynolds 2019-11-08 22:05:25 UTC
https://pagure.io/389-ds-base/issue/50696

Comment 3 Viktor Ashirov 2020-02-17 13:52:46 UTC
Build tested: 389-ds-base-1.4.2.7-1.module+el8dsrv+5547+8be68086.x86_64

Directory Manager DN is not editable, but the CSS property shows the input field as 'readonly' instead of 'disabled'.

Moving to ASSIGNED.

Comment 4 Viktor Ashirov 2020-02-18 15:44:26 UTC
I was testing a wrong build. cockpit-389-ds doesn't depend on the same version as 389-ds-base. And I updated only 389-ds-base packages.

Build tested: cockpit-389-ds-1.4.2.7-1.module+el8dsrv+5547+8be68086.noarch
Directory Manager DN is not editable and it is disabled.

Marking as VERIFIED.

Comment 6 errata-xmlrpc 2020-04-29 08:04:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1961


Note You need to log in before you can comment on or make changes to this bug.