Bug 1751019 - Database Backup unable to restore suffix after it gets deleted
Summary: Database Backup unable to restore suffix after it gets deleted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: 389-ds-base
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
: 1751028 1751052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 03:54 UTC by Anuj Borah
Modified: 2020-09-13 22:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-27 10:47:38 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Video1 (3.22 MB, video/webm)
2019-09-11 03:54 UTC, Anuj Borah
no flags Details


Links
System ID Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 3744 None None None 2020-09-13 22:23:59 UTC

Description Anuj Borah 2019-09-11 03:54:52 UTC
Created attachment 1613900 [details]
Video1

Description of problem:

Database

1. Create two suffix
dc=example,dc=com
dc=example1,dc=com

2. Backups & LDIFS > Backup

3. create a backup

4. delete both the above suffix

5. Try to restore again with the backup just taken 


Version-Release number of selected component (if applicable):
389-ds-base-1.4.1.8-1.module+el8dsrv+4209+f45880df.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ding-Yi Chen 2019-09-11 05:51:09 UTC
I can also reproduce this bug.

Comment 2 mreynolds 2019-09-11 14:28:40 UTC
This is expected behavior though.  How can you restore a database if you don't have a database configured.  I will add better validation, and improve the error message, but it should not be expected to work.

Comment 3 mreynolds 2019-09-12 18:20:11 UTC
*** Bug 1751052 has been marked as a duplicate of this bug. ***

Comment 4 mreynolds 2019-09-12 18:22:23 UTC
*** Bug 1751028 has been marked as a duplicate of this bug. ***

Comment 6 Viktor Ashirov 2019-10-29 21:14:51 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

I'm getting the same error as in the attached video:
Failure restoring up server - Server is unwilling to perform

I'd also add some explanations to backup tab about what can be backed up and what can be restored since the user might be under impression that the backup can restore instance completely with all suffixes.

Moving to ASSIGNED.

Comment 10 mreynolds 2019-11-06 14:13:46 UTC
This is not a problem with the CLI or UI, it's in thecore server.  Changing component...

Comment 11 mreynolds 2019-11-06 14:15:37 UTC
Upstream ticket::


https://pagure.io/389-ds-base/issue/50689

Comment 12 Viktor Ashirov 2020-02-27 10:47:38 UTC
This is fixed with the latest 8.2 build, closing.


Note You need to log in before you can comment on or make changes to this bug.