Bug 1751079 - Keep MTU settings of interface if possible after base interface MTU changes
Summary: Keep MTU settings of interface if possible after base interface MTU changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1751695 1770691 1779162
TreeView+ depends on / blocked
 
Reported: 2019-09-11 07:02 UTC by Ales Musil
Modified: 2020-04-28 16:54 UTC (History)
13 users (show)

Fixed In Version: NetworkManager-1.22.0-0.1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1770691 1779162 (view as bug list)
Environment:
Last Closed: 2020-04-28 16:53:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproducer (2.78 KB, text/plain)
2019-09-11 07:02 UTC, Ales Musil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:53:59 UTC

Internal Links: 1751695

Description Ales Musil 2019-09-11 07:02:09 UTC
Created attachment 1613928 [details]
Reproducer

Description of problem:

Considering scenario eth0 and two VLANs on top eth0.10 and eth.20 all of them with MTU 2000. When we change the MTU of eth0 and eth0.20 and apply this config the MTU of eth0.10 is reverted to default value (1500), but in the NM has still 2000 in the config. 


Version-Release number of selected component (if applicable):

NetworkManager-1.20.0-3.el8.x86_64

How reproducible:

100%

Steps to Reproduce:

Full reproducer is in attachment. 

Actual results:

76: dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 2200 
77: dummy_abc.10@dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 
79: dummy_abc.20@dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 2200 


Expected results:

76: dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 2200 
77: dummy_abc.10@dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 2000 
79: dummy_abc.20@dummy_abc: <BROADCAST,NOARP,UP,LOWER_UP> mtu 2200

Comment 2 Edward Haas 2019-09-20 09:22:16 UTC
Can you please target this for RHEL 8.1.1?

Comment 5 Edward Haas 2019-10-29 09:25:33 UTC
(In reply to Beniamino Galvani from comment #4)
> (In reply to Beniamino Galvani from comment #3)
> 

Editing the MTU/s on a server, especially on a hypervisor is a common practice and supported by layered products like RHV.
This problem seems like a regression (seems to have worked before) and it is too basic not to handle as soon as possible.

Comment 7 sushil kulkarni 2019-10-29 14:27:12 UTC
Setting flags for inclusion in 8.1.z.

Anita, can you please approve this Z stream request by setting zstream+ ?

Thanks!
Sushil

Comment 11 errata-xmlrpc 2020-04-28 16:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.