Bug 1751081 - ModuleNotFoundError: No module named 'prettytable'
Summary: ModuleNotFoundError: No module named 'prettytable'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-11 07:07 UTC by Sunny Kumar
Modified: 2019-09-11 09:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 09:40:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sunny Kumar 2019-09-11 07:07:29 UTC
Description of problem:

New test case is failing with below error:


from prettytable import PrettyTable
ModuleNotFoundError: No module named 'prettytable'



Additional info:

https://build.gluster.org/job/centos7-regression/7694/console

Comment 1 Sunny Kumar 2019-09-11 07:12:37 UTC
Form gluster spec:



 686 %setup -q -n %{name}-%{version}%{?prereltag}
 687 %if ( ! %{_usepython3} )
 688 echo "fixing python shebangs..."
 689 for f in api events extras geo-replication libglusterfs tools xlators; do
 690 find $f -type f -exec sed -i 's|/usr/bin/python3|/usr/bin/python2|' {} \;
 691 done
 692 %endif

Comment 3 M. Scherer 2019-09-11 09:40:58 UTC
I closed that because I think this do fix the bug, but if this is not sufficient, of course, do not hesitate to reopen.


Note You need to log in before you can comment on or make changes to this bug.